Prime 4 1.5.2 WiFi Login Failed

Hi I seem to have 2 issues which may be connected.

Firstly, I’ve been using my P4 for awhile at home connected to WiFi with a Beatport Link account (still active and paid up) but suddenly it wont connect to my home wifi network.

When I go to settings to enter the WiFi password I get a “WiFi Login Failed” message.

So I tried my smart phone and it connects fine to my smartphone hotspot, but then I get my next problem, it lets me log in to Beatport (accepts my username and password) but when I go to access my playlists in the menu I get another error message

“Beatport Link error - we are unable to contact the srrver. Please check your internet connection” OR I just get a spinning wheel on the Beatport logon page.

I’ve reset my router and forced the controller to forget the WiFi network but nothing seems to fix either problem, and now to compound the issue, strangely I no longer have the option to forget the network?

Can anyone help with this please?

Thanks in advance.

Did You tried to do factory reset on the Prime 4? If not do that and try again to connect. If that does not help, try to re-install the newest update.

Thanks for the reply. I’ve tried a factory reset with no improvement. I’m on the phone to Denon now to see what they suggest but I’ll also try to download the latest update as you suggest. I’m concerned I can’t even forget the WiFi network details now (even after a reset it doesn’t prompt me for the password and hasn’t got an option to forget the network) so I’m stuck with this loop of an error message.

Change the SSID on the router with new key of just text and numbers, the P4 will see this as a new network rather than using any cached WiFi settings.

Great that you’re in contact with Denon. Keep us posted.

Cheers for the suggestion, I tried that and no luck, it still tries to connect without prompting me for a new password and doesn’t offer a “forget network” option.

Denon referred me to the US after not being familiar with this error. They walked me through everything I’ve already tried (factory reset, router reset, soft reset, password change on the router etc) :confused:

I’m waiting for a call back now from the US (I’m in the UK)

Thanks for the update. Starting to sound like a malfunction that needs a look under the hood. Again, please keep us posted.

Hi @Crymshady - Are you able to plug the unit into your router directly and not use Wi-Fi? Would be a good data point to have and might indicate the Wi-Fi on your unit requires service.

2 Likes

Good shout, I’ll have to find a decent length of LAN cable as the unit is too big to take to the router.

The unit connects to my mobile hotspot fine (albeit then it won’t log into my Beatport Link account, I get a different error message indicating that it can’t connect to the Server?)