Pitch Drifting

Hi everyone

So, been using my SC5000M players for quite some time now and had no issues. Recently though, one deck would start to lose speed and slow the track down that it was playing. Hard to spot when just listening to one track by itself, but really noticeable when mixing. Usually, sliding the pitch all the way up and down fixed it and things were then fine. However, the last day or two they have got worse. I have a video of the problem but not sure how to post it on here so I will try to explain.

I’ve taken the same track that has been analysed in Engine Prime and exported it in a playlist to a USB as I have done hundreds of times. I’ve loaded the track in deck 1. Deck 2 is linked via ethernet cable and I have loaded the same track to that deck also. I’ve put the pitch at zero on both decks and made sure the percentage of adjustment on the screen is also set to 0%. Both pitches are +/- 10%. I start both decks off at as close to the same time as I can by pressing both play buttons together. Within 3 or 4 seconds, its clearly obvious that one track is faster than the other. Anyone who beat matches by ear can tell and the lights on the mixer channels also flash out of time. I get this same issue if I try the track on 2 separate USB sticks, one in each deck also.

I was hoping that this would be an isolated incident but after logging back on here after being away for quite a while, I can see a number of similar topics. Thats worried me somewhat.

I’m going to try and sync both tracks as I haven’t tried that yet so need to see how that affects things. I’m also going to try with the motor off on both decks too.

I wanted to ask really if there are any other things I can try to resolve this? Also, if there is some sort of common fault happening here, how can I go about rectifying it? Id love to hear any thoughts on this and any help would be greatly appreciated. As things stand at the moment I can barely use the players as mixes just drift away within seconds.

Thanks everyone.

Did you try with instant doubles, that will help rule out the human element of having to push play at the same time on both decks.

Not yet. Will try it out with sync etc too. Im pretty certain though that its not a human element thing. The video I have will highlight that if I could upload it.

Host it on (e.g.) YouTube then post the link here.

1 Like

Good shout. I’ll sort that and post the link up here later.

EDITED Here is the link https://youtu.be/Ft35Opjulr8

1 Like

In fact, even it is told 130.0 bpm this may be not. It could be 129.95 and 130.05 so it doesn’t sync perfectly I think. Are the bpm faders with light on ? If you use the sync button, is it perfectly synced ?

It’s a common issue with spinning platters. For troubleshooting first you need to switch platters between the units to see if the problem follows the platter. Also, check the spindle screw if it need to be tightened, I remember that also affects playback.

1 Like

Try it with the motors switched off

Thanks for the replies so far everyone.

Tried a few tests out just now. With the motors on and the platter spinning, the same track on both decks will not keep in time when using sync or instant doubles. If I turn the platter off though, things seem much better. Ive recorded videos of these just in case.

If this is a common issue with spinning platters, how can I go about fixing it please? I know one suggestion was to switch the platters around to see if the issue follows the platter. To be honest I cant see how to get the platter off and dont want to force anything.

1 Like

Just got home I will test on the 6000M.

I haven’t noticed a drift using standalone prior to you mentioning it. Wow and Flutter perhaps

Its some major wow and flutter though as you can see in the YouTube link I posted above

Just tested on a pair of SC6000M

The two tracks stuck together like glue.

No drift here on standalone

1 Like

Loosen the spindle screw and check that it is aligned with the groove in the spindle then apply a slight pressure to the control disk and tighten up the screw (to create more friction between the control disk and the platter)

see if that helps.

i checked the track you used in the video and the BPM detection is ok the only issue i saw was the BPM ID3 field is set to 99BPM when you download it from the artists SoundCloud page so you need to Re-Analyse in engine to get the correct BPM.

All my tracks go through MP3tag then Engine Prime before they reach my players. No analysis is done on the players themselves as far as Im aware.

You take it off in reverse as when u put it on sir. Unscrew the record, take off record, take off slip mat, take off platter its really that simple…as I sad just do reverse as to when you got them & installed the platter sir

Holy thread revival…

Without sounding like Im being an arse, I know how to take the platters off. I know its just a reverse of putting them on which I obviously did when I got the players. However, mine just dont come off. I can literally lift up the entire player by the platter and it doesnt come off.

Bit of an irrelevant issue now anyway as the motors in both players were replaced as they were defective. Not even 2 years old but at least they got fixed.

So it was solved by the new motors or?

Shall I holy close this? :wink:

I have the same problem with one of the motors and I also have a stuck platter. How did you get the faulty motors diagnosed?

Trying to go through my retailer, but apparently Denon are not returning messages.

this thread also seems to concern the same issue of songs not playing at the right speed with the motor on as here:

and here:

It is one of two issues i found on my players which i discussed here:

As of yet no one seems to have solved this except for Harrisonm65 by changing out the motors. For me this is expecially frustrating since the devices i have are practically new. Has anyone here an idea how to track down the issue or fix it without changing any parts?