Philips Hue Lighting bridge is connected but lights aren't changing or responding

I can get my Prime 4 and Prime Go, both updated to Engine DJ 2.0, to see and connect to my Hue Bridge. It picks up the Entertainment Areas but clicking on the ‘test the light’ icons does nothing and the lights are not responding to the music.

Not sure what else to do. I’ve rebooted the bridge and turned the lights off etc.

1 Like

I assume, but just checking, you use Philips Hue Lights which are Entertainment Area approved?

Yes they work with everything else like Hue Sync etc. To be honest, most Phillips Hue lights still work, they just recommend the newer richer colour ones because they are better. I have a mixture of the new ones and older ones, about 50 in total.

Be sure that only one of your Engine OS devices is trying to use the bridge at any given time. You may run into trouble if multiple devices (including SoundSwitch desktop) are trying to access the hub at the same time.

Yeah don’t worry I’m only using one at a time. I had to test though to see if it was device specific but its not.

I’m having the same issue. I’ve got 2x SC5000s and can’t get it to work either.

Update: I have tried the following things to try to resolve it: Ensuring that only 1 player is connecting to the bridge Ensuring only 1 player is connected to the internet Ensuring that no other software is controlling the lights Rebooting each player Reconnecting to the Hue Bridge Creating a new entertainment area Changing the “sync” setting from automatic to manual in the hue app (no idea if that was affecting anything or not) And all of the combinations in between.

I will also add that I may have 2 different models of SC5000 because, on one, the “Denon DJ” logo, to the right of the screen, is white and painted on, and the other is silver and raised. (Again, no idea if it changes anything)

Having the same exact issue and I really can’t figure out the problem.

I can get the lights to signal in the soundswitch software. But not on the prime 4, they are just unresponsive.

It connects and loads the entertainment zone, just doesn’t have any response from the lights

I use Hue bulbs but directly through an Echo Plus, hopefully this can be added as a future update so the hue bridge isnt required.

Exactly the same problem here! I can’t find out what is going on for my life. Tried setting up different entertainment zones, tried 2.4 ghz instead of 5 ghz wifi, router and bridge reset, complete reset of my SC5000, reflashed 2.0 firmware, changed the sync setting to manual in the app, tried both new and “varified” lights only in an enternainment zone and mixed lighting in one zone. I can also see all my zones on my SC5000 but tapping any light the do not react.

One thing I should add: In the top right of the display it always says “connecting” As if a connection has yet to be established. Although underneath the bridge logo it tells me it is already connected.

It just seems to be buggy for now. But I wonder why it works for some people and not for others. Maybe a port problem with the router?

I’d love to see this solved soon. Playing a little gig on a house party next week and the house is full of hue lighting so this would be a great little extra for the set.

Cheers

1 Like

If Engine Lighting says ‘connecting’ in the top right corner of the GUI, try turning Engine Lighting off and then on again to see if that fixes the issue. It may also be worth trying to ‘Clear all bridge settings’ from the hue setup page and relinking.

Another thing to try (if possible) is connecting your Engine DJ hardware to the internet with an Ethernet cable to see if Wi-Fi signal could be the issue.

Is everyone using Basic or Pro mode?

I’ve just tried every thing you have just mentioned and it didn’t make any difference I’m afraid. Basic and Pro modes. Are there any written instructions and guides for all of the options in the lighting section?

UPDATE: Sorry I have just looked at the new Manual so ignore the last bit.

1 Like

Looping in @Matthew.W to see if he has any thoughts or suggstions.

1 Like

Good call bringing in the product manager for that project. It might be worth it to bring in the developer that worked on that particular feature. I want to offer my assistance if I can. I’m a professional software engineer so I’m more than technical and have already found all of the diagnostic tools built into engine lighting. Let me know if you need any of that information. (i.e. versions and whatnot)

I should also add that the diagnostics tab does not appear to be automatically updating the parameters when I change the settings that should affect them. (This is probably unrelated to the Hue issue, but it’s an issue that I noticed nonetheless)

To comment on your previous post, I have also had that “connecting…” issue. I think the cause is that it is trying to connect to soundswitch when the player is booted up, but before the player has had a chance to connect to the wifi and that is causing a timeout issue that isn’t handled because the connection packet is never returned so the connection attempt just hangs. A simple restart of the soundswitch services fixes it consistently. I should also add that all of the testing that I have done (found in a previous post on this thread) has included both basic and pro modes.

I would be willing to bet that the issue is not related to the network or network connectivity. This is because we can still connect to the bridge and can confirm that because we can see the entertainment areas and their lights and positions. I assume that the entertainment area information is something that can ONLY come from the network connection. I still think that the issue is something relating to the software maintaining priority over other programs that are trying to control the lights.

1 Like

Not sure if this has any bearing on this subject but I am also trying it with my DMX lights and I can’t seem to get that working either. Now forgive me if I am being dumb here but if you need a paid or trial subscription to use Engine Lighting with DMX where exactly do we put the serial number in? I can’t find any information on that process anywhere.

Yes I agree, if you can see the bridge and entertainment areas it must be able to communicate with it.

1 Like

For soundswitch and DMX the workflow should look something like: Run soundswitch on your computer Configure your light show in the soundswitch software (where you have to activate the license) Use Engine to export your show to your drive Then connect the drive to the player and your soundswitch info should be there.

Since the players aren’t creating and configuring shows, there is no license needed But in order to create and configure shows, you need the paid soundswitch software

Is that really how it works? I’ve just watched the Digital DJ Tips live Q&A from yesterday with the guy from Denon and I got the impression the idea is to completely get away from the laptop. It doesn’t need to create shows onboard as that what the Autoloops are for. He said autoscripting may come in the future. It just maps the autoloops to the beatgrid. No preparing is required for that surely?

That’s a fair point. I suppose I should clarify. You don’t need to have any soundswitch subscription at all in order to use the autoloops and all that (provided you have the right interface) but I personally don’t have any DMX gear so I can’t really help beyond that