Pc won´t properly recognise prime 4 unit

I plugged the prime 4 unit into my pc to load tracks on to the internal sata drive, some components are visible but neither is the drive shown in the file explorer nor is ist visible in engine prime. maybe some drivers are missing but i coudnt find any on the internet.

please help

Hi Cinzin,

Have you rebooted the Prime4 in controller/computer mode?

Hey Reese, thanks for your reply. Yes I did, I followed all steps recommended bur it didn’t work. In the device manager it showed the device but said the prime 4 audio driver is missing and I can’t find it anywhere online. Thank you

Okay.

I think the Prime4 is class-compliant like the SC’s and X1800, so you won’t need an audio driver. And on top of that, to put music on the internal drive, you should not need an audio driver… :wink: It just acts like an external USB-drive.

Could you tell a bit more about your computer? Windows or Mac, which version etc.

If Windows10: What do you see in Disk Management?

Have you tried another USB port? Or another USB cable?

hey Reese, i solved the issue.

I don´t think the problem was cause by the prime 4 but i used a ssd to usb 3.0 adapter and connected the drive to my laptop. I had to partition my drive an format it to exfat. Then I plugged it in the P4 and it worked. but thank you anyway for your time and effort.

best regards

2 Likes

No problem. The FAT32 > ExFAT question was the next step! :stuck_out_tongue_winking_eye:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.