No Filter on cue?

It would seem that you can only use the filter on the master channel and not on headphone cue? Is a firmware update going to resolve this? Or am I missing something?

1 Like

Across the prime range only some of the fx can be heard in the headphones even on the massive x1800/1850. If they can’t give all fx in headphone on THOSE mixers, then I think there’s no chance for that feature on the prime 2,4,go … those users will have 2 forGo ( :slight_smile: ) the option of cueing some fx