New Software Release: Engine Prime 1.1.1

Engine Prime 1.1.1 Software update.

Important: Engine Prime 1.1.1 is not backwards compatible with Engine Prime 1.0. Switching back to 1.0 may cause undesired behavior and loss of collection integrity. We recommend backing up the Music/Engine Library folder as an extra safety precaution before upgrading. Engine Prime 1.1.1 is compatible with all versions of SC5000.

Bug Fixes:

  • History list order not being consistent between player and Prime

  • Content of history list not being consistent between player and Prime

  • Library Metadata column order was not saved to Prime preferences

Download Link:


Is this new?

It became publically available 6 hours ago

1 Like

Oh seen…updates coming faster than the beast from the east

Keep em coming

great to see bugs being fixed hope we also see soon some new functions added to engine.

Good thing to see faster fixes!

Hello, I am very interested in testing the beta version of Engine for the MCX8000. Thank you. a greeting

hi i tried dowloading this but all i get is “403 - Forbidden” I there is any other alternative link

kind regards, Ankeet Modi

just tried to download the 1.1.1 version from

and can download both the Windows and the Mac version.

tip: make sure you enter a valid e-mail address.

hi … i have tried it on multiple platforms and legit emails yet same issue. Is it possible to get it emailed to me or alternate links?

kind regards Ankeet

Hi - are you able to see the mcx8000 beta test category in the forum ?

i am trying to download the ENGINE PRIME software. Already downloaded and upgraded my mcx8000 to 2.0. kind regards

Can’t get my MCX8000 to sort by genre, artist, title, etc., etc. with the NEW Engine Prime. What am I doing wrong?

Are you trying to sort within the Prime software on a PC or on the MCX8000 itself?

That’s not clear from your post.

Please post MCX8000 2.0 Beta issues in the MCX8000 2.0 Beta Defects and Issues section. There is a template for every new post which helps you report issues in a clear and orderly fashion so that Denon staff can take that information and then reproduce the problem you are seeing.

Help required. I have once again removed all engine software and files from my computer in an attempt to sort the problems out with the analysis of the tracks.

I have re downloaded engine 1.1.1 and turned off auto analysis and Serato so the only thing it can see is my ITunes library.

I have reformatted a Sandisk ultra flash drive 64gb which has been used on MCX 8000 and SC5000’s and started from scratch.

I have checked all tracks in my ITunes library to ensure all are MP3 44.100 KHz and range between 160 - 320 Kbps.

I have taken one of the effected tracks,Bobby Brown, Two can play that game from the album Now Dance Summer 94 which is 3.29 minutes long and copied from ITunes onto the stick along with all other tracks from this album then removed the stick, then loaded into the MCX and away we go, all works well.

So here is the problem. Analysis through engine and this is the same for all versions changes the track length to 1.44 mins all other tracks on the same album play fine. Try to play on the SC5000’s same thing and then try and play back in the MCX and now won’t play in that.

There is no reason these tracks should cause a problem it is totally random they are tracks that are part of albums downloaded at the same time treated in the same way with regards to file management.

I have spent a lot of time and effort making sure that all track are downloaded at source in the same way and only use ITunes as that source so it makes no sense that for every 20 or so tracks downloaded that one or two wont work in engine of any kind.

Pc/ Windows 10 always up to date 16 gab ram

Have any other programs touched the tracks, such as programs to add lost or missing album art, programs to adjust levels, programs to tidy up tags or convert things?

By you managing to isolate particular tracks which are faulty it does give us an opportunity. Could you upload one of the affected tracks to a share service and pm me the link please. Our Declv team can then run some tests on the file.

Hi Gee No, not been touched by any other programmes. Yes, I can do that for you. I have sent some over in the past which were found to be fine and had been told that having looked at them the issue had been escalated to the states to be looked into. Could you let me know how you would like them sent Thanks for your help Steve

Hi Steve

The most likely thing is that something has contaminated the ID3 tags on the files. That could even have been at the iTunes stage.

It’s easy enough to blank out all the tags which are shown on iTunes/Right click etc, but not all of the 85 ID3 tags in a file are shown on-screen. Some tags dictate how the host device plays the file back. With this in mind It might be worth looking at downloading a tag remover program (there are a few free ones) and letting it remove all tags from the files. Add the important tags back in manually, eg: Song Title, Artist etc and see how the track plays and shows time etc.

Alternatively, pop a couple of the files on dropbox, or other file sharing service, if you’re happy to do so, and send me the links and I’ll apply tag stripping etc to the files and send them on to our development team.



Hi Gee I have stripped the track of all ID3 tags and still the same problem. I’ve have sent the tracks via Dropbox for you. 1 track after 1.1.1 had analysed track 2 track with stripped ID3 tags