New Controller does not work with USB/Serato/Engine


My new Denon MCX 8000 is still not working, although I could use a similar Denon 8000 by a friend of mine with the Laptop or either with USB.

My software:

  • Windows 10
  • Driver Windows MCX8000 1.05 installed,
  • Serato DJ 1 9.6. updated
  • Engine installed -MCX8000 Firmware 1.5. updated

Problem: DJ Controller runs - Display shows Line 1/2 or even 3/4 dispites of the chosen deck. Only 3 Buttons are working (View Utility, Load/Select & Back/Clr-Funktion)

Serato: Connects to the MCX8000 but…there is shown a thrue Fault…i can’t load a track by the Controller (stop/play & all other buttons and faders don’t work) If a load a song by mouse click…there is no sound the track is not shown on denon’s displays.

USB: similar - there is no sound the track is not shown on denon’s displays. Just shown line 1/2 on the display…same with Serato.

At my friends Denon MCX8000 it’'s working perfectly.

My Idea: Problems with Firmware 1.5 - I can not get back to the Auslieferungszustand Factory Output - if I set OK it always cancel the step and does nothing… Is there another opportunity to reset Denon MCX 8000 outside view utility. Can’t do anything cause firmware is up to date…

Any ideas to solve the probem?

Thanks for the support.

Greetings MoreQs

Ok so your friends 8000 works on your laptop but your 8000 won’t work on your laptop or his?

And… your 8000 won’t upload firmware.

Did your 8000 work before you tried uploading the firmware? If yes, then it may be that you stopped the firmware upload halfway through and have damaged the firmware - only a return to an authorised service centre can fix a partial firmware upload.

Best to send the unit in under warranty.

Thank you for the fast response.

I’ll didn’t try the controller before updating the firmware. And I was talking about my PC and USB-Sticks working on a friends Denon…but not connecting with my new Controller.

I don’t know if firmware broke up within updating the Controller…i don’t think so…but it’s so bad that there is no easy opportunity to set it back to factory output by another update :disappointed:

Some more ideas?

Did you ever find a resolution to your problem here? I’m experiencing the same issue. Can you advise please?