Needle drop settings?

Just unboxed mines yesterday, however, the RHS needledrop, does notseem to work?? should needledrop work automatically, as in both sides of console or is there a chance i have “turned it off” RHs seems not to be working? just starting to explore and want to make sure its all good… LHS works as it should… before i contact supplier?? thanks

With Firmware 2.1 while pressing shift you can needle drop. how it behaves after that depends on the configuration you have on the firmware. Also you can stop the jogwheel and while holding you can needle drop.

Yeah, thats fine, the LHS seems to do all that, but the RHS doesnt??

Ahh ok, sorry I scan the MSG instead of reading it carefully. I got it now. Try re installing the firmware as a troubleshooting elimination process. If it continues then you really have a hardware problem.

Rolled back the FW to 2.0, still no difference, then reflashed with FW2.1 still dead, i think its a HW issue, i will get it packed up and sent back confidently knowing i have tried most things and its not a software issue, as im sure you cant switch the RHS off and leave the LHS on? cheers for the help Fella.


Get it fix, you will enjoy this controller once is operating normal.

1 Like