[NEED MORE INFO] Tracks Missing

Engine Prime’s export to MCX8000 does not seem to be working for me. I consistently get a “tracks missing” report which leaves out 80%+ of my library. USB is a 32gb Kingston usb that has been formatted properly to FAT32. What am I doing wrong here? This happens 100% of the time and is leaving my MCX8000 completely useless has a standalone device. This is a software fault and not a unit fault, it seems. Can anyone help?

Most time you get a missing File report - if the file has special charakters used - like é è á à ó ò and so on. If that´s the case - rename the file with normal charakters to a e i o u - in tag it can have those charakters without probs. but filename should be as simple as possible. Have had thisi issue also, and it worked for me to rename the files. Other case could be - that the file has a false audio rate. MCX8000 uses 44.100Hz … if you have a track which is Studio-Quality eg: 48.000Hz or 96.000Hz it can also cause errors. Than resample it with an audioeditor to 44.100Hz and it also should play.

Edit: can be a database problem. the database recognizes only latin charakters. They could use a simple fix - when they sort our tracks to our database: the filename can be renamed to a personal track ID - (the tag will not be compromised with that, and if we backup the music later from drive, we could rename it back from tag - not the nicest way, but will ensure to not have missing tracks anymore) (personal track ID can be a number between 000.000.000.001 to 999.999.999.999 - so we have enough space for files)

For the devs: Or even better idea: - let the track filename have its own fingerprint id - that will also shrink the amount of space used on our hdd. because if the file have the same fingerprint id, it´s the same audio, and if we have albums, this ID can be replaced in all Albums to use only one file - no more doubled tracks.- But Audio fingerprinting is a very hard thing to code, I think)

For any bug to be considered for review, the reporter must use the auto generated template. This is clearly outlined here.

For reference, this is the auto generated template you deleted when you posted.

  • Software or Firmware Version: (1.2, 1.3.1, etc…)

  • Steps to Reproduce: (Turn on unit, press button X, etc…)

  • Expected Result: (ex: It does X…)

  • Actual Result: (ex: It does Y…)

  • Reproducibility: (ex: Happens 1 out of 10 times.)

  • Other Relevant Configuration Info: (ex: Plugged into a Windows 10 laptop.)

  • Operating System & Version (if applicable):

  • Link to Video Repro:

1 Like

Classic !..