My X1850 problems

Hey guys, I bought lately an x1850 Mixer and found four serious bugs.

Just want to share this with you. Let me know about your experience with the mixer.

I want to state that I really love the mixer and that it will be replaced with a new one.

Reason for the replacement:

  1. Sweep effect nob number 4 is not turning of the effect in the middle position
  2. The big Headphone jack has sometimes a loose contact. If you accidentally touch it one of the headphone speaker is going off
  3. The cue-mix nob is far to the right when it’s in the middle position
  4. The effect Touch Strip is working not as it should. It doesn’t release when I take the finger off.
1 Like

I don’t have the X1850, but…

#1 is a known glitch on the x1800 and x1850 seemingly related to the sweep knob deadzones in the firmware not being quite wide enough. Lot of variation in these pots, it seems.

#2 seems like an issue with the pins in the headphone jack needing to be bent back to their proper shape. They’re pretty thin and springy. It shouldn’t be like this from the factory I would think.

#3 - If the cue is not the same volume as that channel wide open with the mix knob at 12 o’clock, that would seem to be a bad pot. Granted, if you’re expecting a cue-mix knob like on a Xone 92 or 4D, then this is obviously a different function than that even when it’s working right.

#4 - Did you have Instant On when checking this?

As for my experience with the X1800s, both of my mixers have done a little of #1 and only one of them right now still does any that I notice. The new firmware may have actually made that one worse in that regard and the other better. One of my mixers had a slight amount of #2 (the other mixer, actually) with one particular pair of headphones, but seems to not occur often. That mixer’s hooked up right now and using a pair of HD580s isn’t having any drop-outs. It might have been just a weird, fat Neutrik right angle connector that was causing it. And I have had none of #3 or #4.

1 Like

Here is a link to a video that I’ve record today. [My Denon X1850 bugs]!dHZzaG93X2VwaXNvZGUtMzMx)

I can’t tell from the video if you have instant on. Looks like 3 is just pot alignment, but since you have other issues I wouldn’t try fixing it yourself.

1 Like

Buying pro gear should not be a headache right from the start; it’s simply unacceptable. I am glad you are getting it replaced.

None of which are bugs.

Those will need repairs rather than firmware


There is a new firmware out for the X1850 v1.1, and so far it seems to have sorted out the problem with sweep effect and filter 12 o’clock issues.

Let me know how you find it

Oddly, the new firmware eliminated the problem on one of my X1800s and made it worse on the other.

With 1.3 you mean? X1850 has another firmware version.

You’re saying the X1850 has an even newer firmware than the last one that came out for the X1800? I realize they each have their own firmwares, but I thought they were basically the same aside from the quantize function… like the same base code.

I don’t know, but it seems different otherwise both would have the same version.

And yes, quantize is a difference.


It has release notes attached when you download the file.

I only had channel 2 Filter & sweep fx 12’oclock issues. Which has fixed the issue and the other channels are fine.

So don’t install on the x1800



In the meantime version 1.0 is available to revert to:


I am having difficulties as the bpm on the assigned channels does match the bpm of the tracks on the player interestingly however I found that moving the pitch fader to the bottom will match the bpm but obviously alters the pitch any ideas? I have tried re assigning the channels but it doesn’t seem to work so it’s putting me off using the beat fx as it’s not on beat.

Check your connections (RCAs & Ethernet cable) using this image.


I found a new strange behavior.

The mixer stops working / no sound at all when I start flanger / phaser effect and start to scratch.

Here is a video: Flanger / Phaser kill the mixer

have you tried the same test on other channels? just wondering if there is an issue with your CH3 every time you hit a particular frequency. If that’s the case, then the issue is with the channel of the mixer and nothing to do with the effects.

I haven’t tried it yet. Will do that next time this happens. But that must be a software bug. After changing the effect timing it works again as usual.

And I can’t reproduce it again.

1 Like

What firmware are you on btw?

The firmware is 1.0