MCX8000 Crossfader Doesn’t Work (even after installing a new Innofader mini)

Hello all,

I purchased my MXC8000 used and in great condition. I play on it all the time and generally like it, except I’ve never been able to get the crossfader to function. I assumed this was a bad crossfader, as I’ve read this unit can have crossfader issues.

I replaced the stock crossfader with an Innofader Mini, and still nothing in either standalone or PC mode.

But! The crossfader is registering. In Serato, I have tried disabling the crossfader and re-enabling it. When disabled, if I move the crossfader, I get a warning flag at the bottom of Serato which says something like, “warning: crossfader disabled.”

So the crossfader is communicating to Serato, but not affecting my sound output at all. This is in all modes. I’ve tried linear and power settings. I’ve tried all positions of the crossfader curve knob.

I am running the latest version of Serato (2.1.2) and I am running the latest firmware for my MCX8000. I put the latest .bin file on a thumb drive and went to update my device just in case, and my device says “up to date.”

I’ve had some issues with this unit since purchasing it, but all have turned out to be connectivity issues. At first, I couldn’t get the device to interface with Serato. Turns out it was a firmware that needed upgrading. So I’m reasonably confident this will turn up to be a connectivity/compatibility issue as well, especially since Serato recognizes the movement of the crossfader. I don’t think the unit itself is defective.

Thank you to all in advance, Kalie

Might be a bad crosfader curve knob. If that goes bad I can see how it would display the issues you are having in both controller and standalone mode, even after putting in a innofader.

In the Mixer settings of Serato, when I adjust the crossfader knob, I can see the setting changing. So Serato is also recognizing the input of the crossfader curve knob.