MC2000 - not recognised as device

Hello there! This is my first post here.

I have recently bought a Denon Dj Mc2000 controller and I would like to use it with Traktor Pro 3.0. Tried to connect the MC2000 to the computer, but when I plug the USB in the following happens:

  1. lights run through all the LED buttons
  2. then all buttons light up at the same time
  3. then only the two VINYL MODE buttons (next to the jog wheels) stay lit
  4. the rest of the buttons/knobs seems unresponsive
  5. checking the USB/audio devices the MC2000 is not listed, does not appear

If I start Serato or Traktor, no device is being detected except my built-in soundcard.

I know this is a legacy product, but as this site notes, the hardware is supported on MacOS Mojave. https://www.denondj.com/kb/2428/

I am using: MacOS Mojave 10.14.5 on MacBook Pro (early 2015) 8GB of DDR3 2.7GHz Intel Core i5 CPU

Hope someone can help, and I am just missing a simple step.

Did you try following the Serato troubleshooting guide that covers mac os not detecting hardware?

Don’t forget there are some things to set to get deck numbers right if I recall correctly.

Hi DJ_Vintage, thanks for the response. My system does not see the MC2000 as a USB device at all, so I don’t think I can set deck numbers or any other features in relation to it. It sounds like that is something I will need to think about once I get the Mac to recognise the controller, so a good point indeed, but probs for later.

Won’t be back to my 2000 and Mac for another week or so. But if it’s not fixed by then, I’ll hook mine up. Can’t check Traktor though.

1 Like

Hi SlayForMoney! Thanks for the quick reply. If you mean this guide:

then yes, I tried all USB ports not using any USB hub and no other USB device is connected. Also, there is no driver needed (as far as I know, but correct me if I was wrong) for Mac so did not install any.

This link is a more general troubleshooting guide, do you know about one that is specifically for MacOS? Cheers

Yes, there is: