Master level meters not working

Hello everyone, just received my unit today and as said on the title the master vu meters are not lighting up (the channel meters do), I cannot find any settings for it in the utility menu, thoughts?

are you using power speaker or non-power? also where is your master knob setting at? trying setting your speaker volume to 9 o’clock and you master to 12 o’ clock to see if the meter jump up

Using KRK Rokit 5 G3’s with volume set at 12 o’clock and master level set at 10 o’clock, also tried other settings, no dice, already contacted the seller, just waiting on the response. Please see vid below:

Strange mines does that too but I have my power speaker to 9 o clock also my gains are around 12 o’clock too . That’s the only way my master meter show up

Can anyone from Denon DJ support chime in?

What happens if you set master level at 12 ?

Finally figured it out, maybe because I came from Pioneer DJ gear and Native Instruments but I have to set the channel gains and the master to about 12 o’clock at least for the meters to light up, thanks for all the replies, much appreciated.

The master knob has a 0 indication in the scale, which is about right when you have the gains between around 11 o’clock.


That 0 is the master stage’s ‘unity’, where the output from the master pot is the same level as the input into the master pot… obviously in the digital domain in this case since the audio isn’t electrically going through an actual potentiometer. Always put the master at unity, otherwise your metering will be off and so will your record out, recordings, booth out, etc, as you won’t know what the signal level is after the (virtual) mix bus. People tend to either crank and clip the channel stages when the master is too low or have the channel stages low when the master is past unity. IMO, the master pot doesn’t serve a whole lot of purpose. An adjustable rear analog pad for the XLRs on the back would be more useful. Since it’s got a master knob, it shouldn’t even allow past unity, but on the X1800 at least you can change it in the preferences so the master at max is always unity. On these all-in-ones you’re stuck with that 0 ‘sweet’ spot.

I was using my Zedfx 10 mixer to control my output for gigs but for streaming I would rather use the master on the unit itself.

Not advisable. Better to control your level into the stream on the USB audio interface or the computer. Does the Prime 2 go USB audio into the computer without needing another interface? You shouldn’t have to worry about levels if it does when the master is at its unity. The streaming software should take the levels as-is. If you go CoreAudio, ASIO, Windows Audio, etc, the zero nominal on the meters will be at -18dB below full scale clip. Proper metering will put peaks for most music somewhere between that and -8dBFS when the music is in full swing, with that 8dB of headroom for effects and mistakes assuming you try to stay out of the second-to-top LED. Don’t be afraid to go into the white, just don’t intentionally use it all up… you need some gain for tracks that need oomph, and you need safety headroom in the form of that top white. Once you’re in that top white, you’ll have no way of knowing how close to the brick wall you are.

I’m assuming that my lappy will recognize the unit as an audio interface (haven’t checked it yet), it has with other devices (S2 & R1), thanks for the info.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.