Issues connecting to Serato

Just trying this for the first time and Serato displays a connection error and Try Again (after a short while) when connecting the Prime 4. It does get as far as showing content on the main screen and it does respond to navigation on the laptop. Nothing on the controller works though and the Midi button at the top of Serato screen remains greyed out. Any ideas of where I should start in terms of trying to resolve this?

What software You have on prime 4 and what serato version?

Check Serato’s website. They have troubleshooting & optimization help for both PC and Mac connectivity issues.

Check the link below:

Thanks - now resolved (driver issue).

That said, I note you can’t select a track from the touch screen only using the dial. Is that correct/expected behaviour?

UPDATE: Tried re-starting everything and touch screen still doesn’t work for selecting track etc. Seems odd that the touch screen doesn’t work for this and you have to use a combination of touch (for side bar) and dial to navigate library etc. Is this the intended behaviour?