Isolating possible PHONO input issue, no sound

Hello, my X1800 is 18months old, until now, working perfectly. The PHONO input has possible died, I only have a single deck, so not sure if its the Deck output OR the X1800’s phono circuit. My Deck will output via USB to PC, so that maybe OK. However all phono inputs have no sound from my deck. This has previously worked fine for 18months. Is it possible JUST the phono input could die like this?

Can anyone think of a way to check the PHONO input with another device? cheers,

When you say deck, you do mean an actual record player, right?

Yes, Audio Techica AT-LP1240-USB

After quickly looking at you turntable specs, Can you tell me whether your turntable is set to preout line or preout phono?

You could check the phono inputs by simply connecting one end of an RCA to RCA cable, then touching the unconnected end with your finger. If you hear buzzing, that’s a good thing. :slight_smile:

cunning plan, thanks… no noise at all…mmm, looks like a hardware issue. I’ve just tried updating firmware to 1.2 as i’ve noticed a 1.3 is available, that hangs on receiving data and never completes… sounds like issues all round.

Whats the Warranty on Denon kit? 12 months? is there a repair service available? I guess this sort of thing happens from time to time, but to be honest, its never gigged, never leaves home, and it only used to do a two hour mix once a month for radio show. Just bad luck I guess, or some sort of spike killing the inputs?


So if you switch your turntable to preout line and use the line input on the mixer do you get meter deflection?

Yes, tried both… not moved the line out setting since the deck worked last week.

Bigger problems now, firmware update fails and leaves me in the flashing LEDS mode.

I really doubt a record player will fry your inputs, even when it’s set to line level output (mind you, not a thing to do if you can help it). With what you are describing, it sounds like there is more going on. That said, the X1800 has 4 phono inputs and 4 line inputs. If you were to set you record deck to line out and tried a line input that works with a media player, you should be getting sound. If not, that would still signal something potentially wrong with the record deck?!

Are you using a Concorde-style stylus or a more “standard” shell with cartridge? It is also a possibility that something is wrong with either cartridge, needle or cabling.

That’s the problem with these things, typically there are a lot of options to troubleshoot. And you can only do one at the time. If you do two or more, and the result changes, you still don’t know which of the changes was the defining one.

Good luck and just my 3 cents worth.