Internal SSD drive size limit to 2TB (MBR) or can I use GPT?

I have installed a 4TB disk into the prime 4 but MBR will only allow 2TB maximum partition (and the 2nd section is unustable, cannot split partitions in windows) - It will let me format as one whole 4TB partition in GPT (ExFAT) but then the prime 4 doesnt like it, I get an error message when booting up (saying must be exFAT or FAT32, its already ExFAT) however then it seems to work fine but im a bit uneasy about reliability.

Is there a workaround for this, or future bug fix allowing GPT to be used with no error message. otherwise we will be limited to 2TB max drive size.

Once again its not possible to format into separate 2TB partitions using MBR.

1 Like

And even if you could split it … I think the Prime could not access them as two different “sources”.

As for that amount of music (even in WAV-format that is just an incredible amount of tracks to have bought, even through a pool), I have my opinion on that, but to each his own. With the new streaming options, there really is not much reason anymore to have much more than a core collection (say 750-1500 tracks) that can handle any “normal” gig and perhaps a cross-collection of possible request tracks. In mp3-320-format (no reason to have those “play once in a blue moon”-tracks in flac, you’d be done with about 500GB worth of tracks (around 50.000).

That said, your question is not about that, but about technical aspects of partitioning. Clearly GPT helps break that MBR barrier, but MBR is still the compatible gold standard. It’s changing slowly, but the main limiting factor here is actually the bios. To boot from a GPT-partioned disk, you’d need an UEFI bios. More and more hardware offers that. How that is implemented in other, task-specific hardware like the P4 is another question. Linux (or whatever flavor is used in the P4) basically supports GPT as well. So, I am guessing it will all come down to the bios-support.

Being able to read a disk (as you apparently can after you go passed the error message) is one thing, the main question is can you also write to it.

Again, personally I think a 2TB limit is fine. I doubt audio-files will ever grow much. 24-bit/192KHz has been around since forever in recording environments and still 99,9% of humanity is still on a maximum of 16/44.1 (CD-quality), which quite frankly is more than adequate for all but the most high-end audiophile environments. Heck, lots of people just listen to crap-quality youtube or free Spotify tracks on their 10 dollar earphones.

That said, it’s up to anybody to want more than 200.000 tracks on their hard disk.

I assume that the folks at Denon will look at the demand (how many people want/actually need more than 2TB disk sizes). If it’s high enough I am sure they’ll make it work (technically it’s probably already possible). If not, then you may be out of luck … or have to use a second (external) SSD/HD for your purpose. God knows the P4 has enough USB-ports :smiley:

As always just my three cents worth.

@tommyoz has successfully prepped a GPT disk-type of 4TB formatted as ExFAT using a third party partition tool.

See here:

Another workaround.

Install a smaller SSD 500gb/1TB into the Prime 4 (Fat32) with your core crates, the Crazy in Love and Fatman scoops

Then place that 4TB (ExFat) in a enclosure and use via the regular USB slots.

Another thing to consider with using Fat32 is the single file size limit and believe me the Engine DB files increase exponentially when you start analyzing files, mine is already in the region of 8gb with my library of 71k tracks all analyzed.

This is why I said try to use a 500gb or 1tb drive. It will stop you from loading too many tracks and likely hitting the Fat32 single file limitation.

Yes I saw that and tried doing exactly the same, but didnt make any difference. I still get the error screen.

Not on FAT32 it isn’t. Max file size in FAT32 is 4GB. Or where you trying to indicate that you need to use exFAT because the index files can quickly become a LOT bigger than that 4GB?

exFAT on the other hand supports single file size of 16 Exabyte or something (which you can never reach cause the max. volume size is “only” 128 Petabyte).

So, we should all generally forget FAT32 and use exFAT (also has better cross-platform support, i.e. MacOS).

The question here however isn’t about the formatting, it’s about partitioning and as I tried to explain, that has to do with bios-support (UEFI for GPT).

I could go into details on things like safe MBR mode (preventing older bios systems from overwriting the GPT partition table) and why it is possible for a disk to be read-only recognized even if you don’t have UEFI support, but not support writing. That however is way beyond the scope of these forums, plus - since we don’t have superuser access to the underlying OS of the P4 - a bit of a mute discussion as we have no tools at our disposal to fix things (fix = tweak things to fit our particular personal situation).

It’s always possible for someone to run into what is so euphemystically called “undocumented features” that might help solve a problem like this. But it would be totally at your own risk and the risk can include anything from a totally disrupted (as in mangled) drive, disappearing partition tables, system crashes in the middle of a paid gig.

Personally (and it is just that), I’d either make a 2TB MBR exFAT on that drive and accept that it’s only giving me half capacity, or take out the 4TB drive and use that in my computer and put a proper 2TB drive in my P4.

Again, if 2TB doesn’t satisfy your need for musical space, then perhaps the P4 option is not the best one for you and you should use a regular controller with a laptop?

My 3 cents as usual.

Indicating that I use ExFat. I don’t have a P4 so I’m not bound to the Fat32 rules.

1 Like

SOLVED!! - I managed to do the same as @tommyoz and used DiskGenius. The issue was, when formatting in windows, by default it creates a little tiny windows reserved partition just before the main ExFAT partition, and that is what was creating the error. With DiskGenius this doesnt happen, and the whole drive is used when formatting to ExFAT. So now it is in GPT mode, and I can use the full 4TB. :smile: Success! :smile:

Oh to add, the P4 does indeed write to the SSD, as I simply added some music on there and it was able to self analyse and create the ‘Engine Library’ folder.

Perhaps Denon may like to point this out to save people future headaches, maybe a note with the quick start guide or similar.

2 Likes

So after my first advice you did the same, but it didn’t make any difference and then you did the same and it is solved?!

LOL!!

Glad it’s solved.

There were one or two quirks but I got there. my main point aswell is also pointing out why the error message comes up due to the small windows partition. Bear with me… I’m a vinyl DJ by nature :smiley:

1 Like

Haha no worries mate. My roots lie in vinyl also.

1 Like

Glad you got it fixed! Indeed something for the FAQ section :smiley:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.