Internal hard drive not recognised by prime 4

Hi, I recently bought a prime 4 over the weekend and decided to buy a internal drive to store music. I have bought a Seagate Barracuda 2.5" Sata 1TB (HDD) and installed into the bay under the unit. However when I turn the prime 4 on it does not recognise the drive. I tried hooking up the laptop and putting prime into controller mode but still no drive is shown. Did I do something wrong?

About to return drive to shop. Can I not just use an external hd instead and format it using exfat? and if so, does it need to be powered by mains or can the prime power the device?

Return the drive and replace it with an SSD. An HDD won’t last very long with all the vibrations that it will receive!

Once you buy your SSD, format it as MBR/ExFat on your laptop then install it into your P4.

Hi Jack,

Do you have Apple or Windows? For windows PC’s you first you have to format the drive Ex-fat file type, then install it into the P4.


Hi @JackJarvisEsq, I’d agree you are better off using an SSD, you’ll also need to make sure it’s formatted MBR as FAT32 or ExFat.

This video hopefully will be helpful:

Regards J

Oh, I just assumed I could format while the drive was mounted into the prime 4 by connecting the laptop into controller mode. Problem is the laptop does not recognise any drive installed, so I cant format it. I have just ordered a Sata to usb cable so I can hook it up to the laptop and see whats happening.

Hi Jack,

On Apple that’s the way it works. On windows pc’s you will first have to format the drive separately from the P4, before you can put it into the P4 and put your music on it through Engine prime (when connected via usb and P4 in controller mode). I’m sure it will work once you have formatted the drive. Best is to use ex-FAT.




Thanks René

Is that still the case?

That’s crap if you can only do it that way with Windows, they should have supplied a cable to do that

1 Like

That’s not true. You can format the drive when it’s inside the Prime4.

hi reese, yes i found that after lots of searching, i thought the info for windows would be easier to find…

Mac or Windows is no different. The Prime4 acts as an external USB drive, so if you know how to handle those it all should be second nature.

100% agree - I couldn’t format the harddrive with my PC but as soon as I hooked the Prime4 to my Mac. It worked no problem. Once formatted it worked perfectly with my PC or Mac.

Mac or Windows is no different.

This does not appear to be correct… I am experiencing the exact problem as others above, where a raw drive does not show up to a Windows computer when in controller mode (formatted USB sticks do) on v1.3.3. Also, there is no easy way to even verify the drive is present/seen by the P4 unit (they should add some sort of diagnostic view to Utilities or something so we can verify what drives/devices are ‘seen’ by the unit at different abstraction layers (hardware, filesystem, etc.).

I stated therefore “if you know how to handle those”. If you do, use disk management to partition and format the drive. Either on Windows or Mac.

Hi Reese,

Thanks for your reply; I now understand the point you’re trying to make but I think a lot of folks may not know all the Winternals necessary. For folks having trouble:

  • Disks (of any sort) must have a partition table mapping the raw geometry of a disk to logical drives addressable by computer operating systems. This is generally referred to as “initializing” the disk.
  • Once partition(s) exist, the computer can then “format” it with a specific filesystem type (we want “extended FAT” or “exFAT”) so that the disk is usable.
  • Most raw disks (straight from the manufacturer) do not have a partition table defined (“unitialized”), leaving that to the computer/end user (there are a few different partition table types)
  • The Prime 4 apparently does not have the capability to create or manipulate partition tables, which means you need to do so when attached to your computer while the controller is in Controller mode
  • The way Windows and Mac handle raw disks (that need a partition table) is very different.
    • Macintosh handles initialization and formatting the disk in a single operation by exposing the raw (uninitialized) disk once it’s plugged in.
    • Windows only displays initialized disks under My Computer. To see uninitialized disks (and to initialize them) you must do so through Disk Management.

So, for Windows users who can’t see an internal SSD on the P4:

  1. Start Menu
  2. Type “partition”
  3. Click “Create and format hard disk partitions”
  4. Look through the list at the top (or bottom) for a disk that has no file system and matches the capacity of the size you put into the controller.
  5. Right Click -> Initialize Disk
  6. Pick MBR and OK
  7. Format the disk (exFAT) and assign a drive letter if needed (all in right click menu)

You should now be able to use the disk. For more information, see this article from Microsoft.


I already made a small tutorial on this, but it’s not in the manual and requires a search on the forum like your post will also eventually be one:

1 Like

Awesome write up! It will probably be easier for people to find if you include something in the subject line about “for Windows” (as I suspect this is how people will be searching for this info).

Also, Denon friends, please consider:

  1. Adding the above to official docs
  2. Add init disk capability to P4 onboard capabilities (GPT support would be nice too)
  3. Add some sort of hardware / disk info or explorer capability to utilities to help users figure out the problem before having to track down this forum thread.


Hello, I am not sure whether you have solved your problem, but I think you can try to uninstall the Hard Drive and then Reassign the drive letter to the hard drive to solve this issue, here are the steps, hope it still helps:

  1. Press Win Key + R to and then type Devmgmt.msc to launch the Device Manager.
  2. Go to Univeral Serial Bus Controller > Choose the device with an unrecognized icon.
  3. Right-click on it and choose Uninstall. If you still can not solve the issue, you can check this article, it lists so many ways on solving HDD not reading issue. Have a nice day.