I’ve just updated my prime 4 to 1.5.1 now it’s stuck on load screen! Help

I’ve just updated my prime 4 to 1.5.1 now it’s stuck on load screen!! Help It’s not coming on all lights are out just says engine prime on screen and stuck there!!

1 Like

Have you tried to hold the Powerbutton for a few seconds, to do a hard reset ?

Yes and it just comes back on that screen and won’t go any further, I’ve also held eject and updated again same issue??

hmmm … from which version do you come ?

Maybe you can flash an older version back, and than try it again. Sometime Engine OS takes a while after a Firmware update. Because it converts its database to the actual version.

But it should not take longer than a few minutes.

You could also try to flash to an older version, do a factory reset in this old version and then do a new update to the final 1.5.1 …

But it should not stuck.


Is this still an issue - has any of the problem-shooting steps that DJDark has recommended been helpful?

I’ve written this as part of another post, although it’s probably worth posting here:

For people who are having booting issues while updating: While it’s probably a bit early to give an official statement on this - it does seems like people (@DJMarcoMarco, @jamm) who had problems seem to have resolved the issue by downgrading by computer (holding eject when turning power on) and then updating using the USB/SD card update method.


DJDARK If we do factory reset, on which software version it will reset? on version which we bought with controller or latest installed ih have now 1.4.

Factory reset means only, that all settings, that could cause problems will set to factory defaults. It will not remove a firmware … you will stay at the last version you do the reset.

Yesterday I try, I reset, to factory settings, and hard reset with power buttonand still stuck on loading screen. As well When I switch on the unit i get message NEW FIRMWIRE (1.5.1) AVAILABLE . And there is option REMIND LATER IGNORE. But I remember when I was updating to 1.4.0 in similar screen notification was to Upgrade firmwire… What to do next?? :slightly_frowning_face:

Head over to: www.denondj.com Click on Downloads Scroll until you see “Standalone DJ Systems”

Looking for older download versions for the Prime 4? Click here.

Once again, click there on “Standalone DJ Systems” - Prime4

Download Firmware 1.4.1 (PC)

  1. Turn off Device
  2. Hold Eject Button - While Starting Device.
  3. You will see a Screen with a Chip
  4. Stop Virusscanner on your PC
  5. Connect Prime4 with the Blue USB Cable to your PC
  6. Doubble click “Prime41.4.1Updater-Win.exe”
  7. Click that Updater can check for Installed Drivers (OK)
  8. Press Update Prime 4

Cross your fingers … and hope

After transfering the Firmware to the Prime, it updates to 1.4.1 Wait until Prime reboots. You should see now the reminder for new Software. (Leave it - dont press anything) Now after a few seconds, Prime starts updating its devices.

Wait - Wait - Wait . . . Dont touch anything … (It takes some time)

(By the way - I do the same steps right now to be sure it does all I write here.)

Now after Update you should see the reminder again.

Press on (Ignore)

Hopefully you should now can choose your source.

Choose your Source and Test your Device as good as you can. If it works … you can download V1.5.1 again and do the same steps as above with 1.5.1

If it then fails again … youuuuuu know … go back to 1.4.1 how described and wait until we get a new Firmware (Maybe there is a bug for some of the Primes … why ever)

I cross my fingers for you. :crossed_fingers:


Thank you for this! My Prime 4 was bricked after 1.5.1 update. I was able to successfully revert back to 1.4.1 without issue. Working for now and will await for a fix from Denon DJ.

1 Like


Will check if Hashtags will be usefull on the Forum

1.5.1 soft-bricked me too. Revert to 1.4.1 using windows worked, thanks DJDark. After I tried the 1.5.1 USB drive update instead of the windows updater, that actually worked.

I think maybe just the 1.5.1 Windows updater image file is broken? The mac and usb update images are exactly the same, but the Windows one is much bigger

MD5                              Name                       Size
C10FCE1702F3AAD0607FD819B6F5B598 1.5.1 from usb zip.img     76,973,499
C10FCE1702F3AAD0607FD819B6F5B598 1.5.1 from mac app.img     76,973,499
C78FBEC5162CB59816622AE2810399DA 1.5.1 from windows exe.img 91,994,207

hmmm … strange. Haven´t had problems with updating from computer. But with USB/SD it is even more stable. I tested this with the latest. You only have to switch sources first, to the USB-Stick/SD-Card before you click in utilities on update. At my first attemp, I waited ages, to find that out :wink:

After updating to 1.5.1 my prime 4 worked okay for a while but in last 2 weeks it will not play so i installed 1.4.1 again and still it’s frozen. after a while i get a message on screen ( the following peripherals did not come online during reboot : prime 4 mixer) with option to update or ignore, i update and it starts updating prime 4 mixer 01.29. sometimes it fixes it and sometimes it don’t and i have to go through this each time i turn on. Is this a software fault and is there a fix from Denon?

If it sometimes works and sometimes not, then there must be a real problem in the hardware. I preffer to send it to a repair center. Seems that there is a faulty connection or a faulty device in there.