Frustrating issue, Flickering jog wheel on Left Player. Audio stutters

I’ve been dealing with this issue for weeks. Flickering jog wheel on Left Player. Audio stutters. Almost cant use the unit at all. Issue is MUCH worse in vinyl mode.

I’ve tried everything. I even swapped players! Still the LEFT player had the issue.

Anyone else experience this? If so, any resolution?

6000 or 6000M?

Have you removed the foil if its the regular 6

1 Like

Thanks for responding. Yes, all plastic is removed. After another search I discovered that this is not an isolated event. There are at least 2 other threads relating to this exact same issue. So, it seems Denon needs to solve this ASAP. Here are those threads:

Some are saying it could be related to grounding issues which is a shame for a device that made to be installed in venues. I’m going to try a ground loop isolator. No idea if it will work but I will report back.

Anyone else have any luck fixing this issue?

It needs proper grounding and venues especially (should) have that.

I have loads of DenonDJ devices here and none have the flickering described. However, it seems to be location specific, stating the left side, so I would try another place if possible. Maybe at a friends house for example?

On the other hand, it might be a defective set. Then the retailer should exchange them.

What’s really throwing me off is the fact that the right side (Player #2) is PERFECT. No issues. BUT when I swapped the players, the problem was magically swapped also. Meaning the player that was perfect NOW has the same issue and the other was now fine. HUH?!! I also tried swapping only the power cables. Same result! Always the left!

What black magic is this? :weary:

Earth rays… Weird stuff indeed.

Interference from other equipment nearby maybe?

Swapped players, the same power cable was still on the left side? Maybe the power cable has a damaged grounding wire, that’s why everything what is connected to it has grounding issues…?

Since no one else has asked, what are the players connected to?

I had this same issue with my DDJ-SX2 back in the day. It’s more than likely a grounding issue within your electrical socket. That’s one of the BIGGEST handicaps of Static Platters. Either test it with different outlets, or buy yourself a Furman Power Conditioner. I run all my gear through power conditioners now. It’s a worthy investment. You don’t have to buy one of the expensive models. A simple M-8x2 model will suffice.

Hey Taisoul - Sorry to hear you’re having issues. We’ll be happy to take a closer look to see if you need some technical support assistance. Could you perhaps send me a video via DM so I can take a look at what you’re experiencing and get some feedback from the team?

2 Likes

I’ll do that. Thanks. I swapped cables also. Problem stayed on left side. Switched devices. STILL left side. Also someone stated maybe other equipment is effecting the device. But are these not built for rugged club use? If that’s the case, It is a major flaw. But I don’t want to get ahead of myself. I’ll be calling tech support.

I experience this, too. In my case, the left device just reboots. I also swapped devices, power cables, et cetera. I even sent back the units and had them thoroughly tested.

In my case, the solution is very simple. It only happens when the unit is cold. If I connect the device and let it play some random stuff for a few minutes (this includes the rebooting of the device) it becomes stable.

Very weird problem, indeed.

Maybe tell us do you have any electrical devices that are positioned closer to the left player?

I have 1 Klipsch Heresy about 3 feet from the left player angled away from it. I guess I might have to test moving the speaker to the right side and see if that effects the other unit. not a fun job. Pretty heavy. lol.

IMG_9158

@inertiamonster I have them hooked up to a MasterSounds Radius 4V. All on conditioned / regulated power (Tripp-lite).

Also a microphone in between but it’s not plugged in currently.

Radio emissions is a confirmed cause for this. Any thing generating radio emissions near the deck?

1 Like

Not that I can think of. Amazon Fire stick above it on my TV maybe? But wouldn’t that effect both decks?

It would depend how far you deck is from the source. It doesn’t seem like anything is wrong with the deck cause you swapped them and it still remained on the left side.

Your mixer has vacuum tubes?

One thing you could try is to use one deck only with just rca to your mixer and plug into different channels on your mixer just to check if it still flickers.

Look here for the effects that certain rf signals have on the jogs.

https://denondjforum.com/t/player-pauses-music-while-in-close-range-with-a-walkie-talkie/27094

OK so I stripped down my whole set up. I think I might’ve solved the problem but I’m not doing somersaults of happiness just yet. I want to test it out a few more days.

But it looks like an LED light strip (yes remote controlled). Might’ve been the cause of the issue. Consequently, it also seems to have resolved an issue with some hum I have emanating from my system. If this is the solution then it’s a double win.

So for anyone else having the same problem, check your decorative lighting!

3 Likes

If the leds are the culprit it could explain your hum too. Your mixer has vacuum tubes I assume so maybe check if they affect your mixer alone also.

Hopefully this resolves most issues I see here concerning jogs behaving bad out of nowhere.