Firmware Update | X1850 Prime v1.3.0

Hi Everyone,

We’re pleased to announce that a new version of X1850 Prime firmware is now available. This version brings the highly requested Broadcast Mode that allows the main mix to send over USB audio channels 1&2. Making it easy to configure the mixer for use with livestreaming applications. This update also brings a number of usability and stability improvements. More details below!

Download

Release Notes | X1850 Version 1.3.0


New Features:

  • Added Broadcast mode. Broadcast mode sends the main output mix over USB audio channels 1 & 2 for computer applications such as OBS.**

Fixes and Improvements:

  • Fixed an issue where Instant FX was not working for Reverb FX when Noise FX was on (44.1/48kHz)
  • Fixed an issue where Noise FX was not working when Reverb FX was on (44.1/48kHz)
  • Fixed Autogate FX initialization
  • Other various stability enhancements & improvements

Here is a quick setup guide to help you get started with Broadcast mode and OBS.

7 Likes

Excellent - although I don’t do home gigs, I’m sure the OBS settings will be useful to some, and shows the versatility of the mixer and its firmware.

I hope people see the note about DVS being disabled on channel 1 while broadcast mode is on. Perhaps now, would be a good time for denon to establish whether that’s a hardware limitation, or not, of course; to stop the few who might being trying to DVS with OBS (or should that be OBS with DVS?) and might put in a firmware request for no reason, if it’s a hardware limit.

The effects adjustments and enhancements are going to be welcomed far more widely though and it’s great to have them - thanks Denon team

Hi Will Is this likely to come for the Prime 4

1 Like

The DJM900nxs1/srt is handled the same way, so I’m assuming it’s a hardware limitation. It’s rare to see DVS deejays using more than 3 turntables at a time, so it shouldn’t affect too much of the consumer base.

But you just know there’s going to be some old Karen/Keith who’ll create Merry hell at losing DVS turntable four while trying to stream out lol

1 Like

Hi, im confused about this update. Pls help.

On OBS I could already see the USB audio as an input source… What has changed exactly or why would this new mode be better??

Is my current connection through an inferior windows connection?

Perhaps OBS finally solved this input limitation.

I’ve heard the Streamlabs OBS fork is already a better choice.

(don’t use any streaming myself, so can’t tell really)

This works perfect on iOS. Just plug in your iPhone/pad to you mixer and press record on you camera to make videos or stream.

1 Like

This is an issue which affected some users and not others. Personally, I only had the issue with obs, but had zero issues with wirecast. Both on Windows. It was an OBS issue.

What type of cord would I need?

You need something like this depending on the model of your ios device

image

1 Like

Nice. What is it called? I am going to order it now. Thanks.

Camera connection adapter

Do you know if this solution would work with the Prime 4?

Not yet. But I can’t tell you if it will. All I know for now is that you can send/receive midi commands and use the inboard soundcard only in controller mode.

Thanks Wyley1, hopefully one for the future…

1 Like

Installed 1.3 without a hitch. I appreciate all the fixes, guys!

1 Like

Anyone have strange issues after the upgrade?

I know I know this is unlikely the fault of this upgrade, but nothing else changed in my setup. The setup: two SC5000 with 1.4.1 x1850 with the new 1.3.0 release

Players connected via digital, to CH1 and CH4 - second layer is disconnected. LAN connected accordingly “1” and “4”

The player today started to play a song then output went away. Pulled the jog back and forth, all the way to the beginning the song then it started to play again, and I repeated this 3 times.

Now I’m monitoring trying to reproduce…

Can this anyhow be the fault of the new firmware on the mixer?

Thanks a lot.

P.

Update your decks first and see if that helps.

I still try to reproduce, after a power cycle - (off, cable out wait 10 mins, replug) - I never seen it again. The 1.5.x update as I mentioned look to be buggy on SC5000, so I would prefer to stay on 1.4 till the 1.6 comes out - then I try again with the upgrades :slight_smile:

Thanks a lot for the advice!