Firmware Update | X1800 Prime v1.5.0

Tried two computers, USB 3.0 and 2.0 ports, 3 cables, multiple times. I had the same issue with the 1.3 update but using an older computer with a 2.0 port solved the issue, no luck this time. I’ve submitted a technical support request this time.

I remember needing to update 3 times before it completed.

When you power on the mixer now, what mode is it in? Photo or video would be nice to see/check.

This is the long shot but could success with firmware updates have anything to do with the input selectors for the channels being left pointing at USB or DVS anything in the settings which adjusts the way the USBs are used ?

I know there’s not a setting called “stop the USB ports being used for firmware updates Y/n” but I’m just trying to think why x % of people are having more of a time than others getting the firmware in

Right now it just goes through the cascading level LED lights booting sequence in an endless loop, and says 1.3 on the screen:

I can boot into receiving mode no issue:

But this is as far as I get in the updater connected to USB1:


I can connect and “run” the update on USB2 but the level LEDs don’t move on the mixer to indicate progress of the update and of course the update check at the end fails:


I had a similar thought but I also can’t think of why it would matter.

When in update receiving mode, try and use the Updater2.exe in the c:\program files (x86)\DenonDJ\X1800 Updater\STM32 folder.

You can reseat the USB cable if the updater2 doesn’t see the mixer btw, and try again.

No luck with that either.

@inertiamonster have you installed the latest Windows driver?

Yes, actually uninstalled and reinstalled them just to be sure. The console app that is installed with the drivers also does not see the mixer on USB1 but it does on USB2, which really makes me think that my USB1 is dead.

Ok, if USB 1is not recognized on multiple computers, then it may be faulty hardware unfortunately. Our support team will be able to assist you further.

Yeah, I feared as much, what is their response time usually? I put in a support request on Friday evening US CST and have not received a reply.

This new firmware seems to have tamed the loudness of the FX.

I can definitely hear a difference and the VU meters don’t jump when an FX is applied.

Good stuff.


I’m trying to upgrade from Mac and we’ve been like this for about 30 minutes. Is it normal?

The same thing happened to me when my MBP went into sleep mode while updating. Restarting the update process fixed it!

Following up on this if anyone is interested, the mixer when into the US repair center and the main board had to be replaced, it’s now on the way back to me. It was a very easy process all I had to do was get it shipped to them and they took care of the rest, shout out to Sam for all of his help, all in all I wished it hadn’t failed but I’m happy with how it was resolved.