Factory reset

Hello, I am trying to reset my mixer back to factory in order to update my x1800 to firmware version 1.5. Version 1.5 was my last good working version before I updated to v 1.6. Version 1.6 is giving me disconnect issues with Serato as well as some sound issues. I have tried doing a factory reset on the mixer but nothing happens. I also tried running the firmware updater but it just keeps saying that my firmware is up to date and does not present me with any options. Any thoughts? Frustrating to say the least!!

After about 1 hour and 6 or 7 tries i was able to get the firmware to roll back to v1.5. Will test to see if I still have issues. This article helped Problems updating x1800


Thanks for the link to problems updating x1800. Since version 1.6 I have had several problems on my mixer, one of my mixer channels is only sending a right signal to my headphones and amplifier. I am also having trouble connecting to audacity. I will let you know how I get on. Did going back to 1.5 resolve your issues?

Not sure if reverting back resolved anything because I still experience the same issues. i have tried 3 different laptops and they all do the same thing. I have been troubleshooting with serato and the problem still persists. I use it in standalone as an option, but when i livestream i play video’s so I need serato for that. Serato says that i have too many usb connections going on. ■■■. You have to connect via usb if you want to use serato! I have tried many setup variations changing out usb cables and everything else but the mixer still disconnects from the laptop while playing and i have to power the mixer off and on in order for it to work. Very Frustating.

To add to my woes I am now experiencing some strange sound issues when I am using the mixer and players in standalone mode. At random points the bass will dropout of the mixer which produces a very whining treble sound, I had to power the mixer off and on to get it back to normal. This happened to me several times during my livestream. There has got be something going on with the mixer, when i use my pioneer controller I don’t have any issues at all. I didn’t have any of these mixer problems before updating to firmware v 1.6. Now it seems that all is lost.