Engine PRIME v1.3.3 won't open

Hi guys everything has been working fine for me with the previous version, I’ve downloaded v1.3.3 but when I go to open it, it waits a short time before giving me this message. I’m using a Mac with all the latest updates, has anyone had the same problem ?

Thanks for reporting this @EyeDJ,looks like you’ve already updated to MacOS Catalina.

Like the majority of the Audio software industry, Engine Prime is not yet compatible with MacOS Catalina, we hope to be able to announce official support soon, but in the meantime, your best option would be rolling back your OS to Mojave until official support has been announced.


Thanks for that quick reply KDonaldson, looks like a waiting game then lol.

Cheers to you to.

You could temporary disable the mac gatekeeper for the engine prime installation. User terminal and enter sudo spctl --master-disable After installation enable the gatekeeper with terminal sudo spctl --master-enable That works for me…


Now that sounded a little daunting at first but was quite straight forward after I googled how the find the “Gatekeeper” like you say it worked for you and I can happily it worked for me to. Lepfert thank you for that advice my friend.

It’s also possible to right click the file, instead of double click. Then select Open, and confirm. The not signed/notarised EP 1.3.3 program will then install normally. Using this method, there is no need to disable/re-enable Gatekeeper from the command line.