Engine Prime 1.2.2 Not Working


I’ve got a Windows 10 PC that I use for prepping the music for my stick.

Since the 1.2.2 update, its now now showing in the screen. I can install it, launch it, the splash screen shows but then I’m left with the icon in the bottom bar and when you hover over it, theres just a plain white screen.

Any help would be great.


This sounds like it may be video card related. Can you make sure you have the most recent version of your graphics card drive installed? If that still doesn’t help, check back with us.


Cheers Vince. I’ll have a look into that. Im sure its the latest driver. I have a Nvidia 1050i but i’ll go check it out just now :slight_smile: :+1:


Do you use a second monitor sometimes by any chance? I’ve had this happen when on a dual monitor setup and moving prime app to the secondary display, then when the second monitor is disconnected, this happens.


Have a look here. On my laptop I had an Intel card and a Nvidia card. Just needed to start it once with the Nvidia card and from then on it worked…