Engine DJ - scrolling with trackpad way too fast

Old thread, same issue on v 2.1.0: scrolling too fast with trackpad

Engine DJ version 2.1.0 seems to still struggle with this on Windows 10 (Razer Blade 15 advanced). The problem seems to me like that the scrolling has way too little (or too much) inertia and even a slightest flick on the trackpad causes tracks and playlists to scroll multiple pages and due to inertia the scrolling does not stop. This means going through the playlists is a pain in the a**, as it’s very hard to hit the right spot on a playlist when the list just keeps on going and going and going.

I’ve tried global options on windows and disabled e.g. mouse acceleration and tried to set scrolling to 1 row only, but nothing happens. Scrolling also works just fine on other software and Engine DJ is the only one which is affected.

Any ideas? Yeah, I know I can use an external mouse and it works just fine, but when using laptop on a lap it’s kind of moot option.

p.s. I can provide a video, just contact me and I’ll send it via email.