Engine 2.0 lighting X1850, SC6000

I tried out Engine 2.0 briefly last night. What a great update - a lot of improvements everywhere in the details.

For Soundswitch, I plugged in my DMX adaptor to one of the SC6000s and it drove my lighting, just as expected which is fantastic - freeing up my MacBook for other tasks and making this a very worthwhile feature. But I still seem to have a problem (that I also encounter when using SS on a MacBook) with getting the second layers to function where I can’t quite work out the cause or solution. I suspect it’s a bug, but I wondered how everyone else is getting on with this setup? Maybe there is something unusual about my setup.

Setup: X1850, 2x SC6000. The X1850 is connected to the LAN via ethernet, giving me wired internet connectivity.

I normally power up the X1850 first, followed maybe 10s later by both players. I have the SS DMX adapter plugged into Player 1. Player layers are assigned to fader channels 1-1B 2-1A 3-2A 4-2B.

Raising fader 2 or 3 (for the A layers) seems to work the lightshow pretty much all the time, but raising fader 1 or 4 for layers B frequently just gives me darkness).

Trying to fix this by either restarting the mixer, or one or other of the players sometimes works, sometimes not. I’m not sure why it’s getting into or out of this state in the first place. Maybe it’s related to being connected to a LAN with a DHCP server, or maybe that’s irrelevant. Has anyone else seen a similar problem, and do you have a similar setup?

I think it would be really helpful if SS had a debug window that could indicate the connection status to the hardware, or record a trace log. e.g. Indicate the sensed hardware and fader positions, that a track has been loaded, that the track has an associated lighshow vs. falling back to Autoloops etc… so I could check it’s detecting my setup as expected.

As long as the X1850 has been updated to version 1.5 Engine Lighting should work fine for your configuration. Just curious, have you tried removing the internet connection to see if that makes a difference?

Looping in @Matthew.W who may be able to assist further.

  • switch on both players first, before mixer.

  • keep an eye on the CUE buttons make sure all of them show the color of the assigned layer as per your settings.

i cant remember if you need to have Engine Lighting in 4 deck mode to use it with the layers. but i think you do.

I updated the X1850, I’ll try removing the LAN connection to see if that is relevant or not.

I’ll try switching on the players first as you suggest. The cue buttons are right - the mixer shows it’s linked.

For Soundswitch I’m pretty sure on the laptop it needs to be 2-player mode for 2x SC5000/6000 and “External mixer” should be unchecked (the X1850 is treated by SS as an “internal mixer”. I exchanged an e-mail with Liam at SS about this.

Disconnecting the LAN didn’t help. However, I noticed some weirdness with engine connect. A long press on the X1850 Engine Connect button was only calling up the configuration window on player 2, not Player 1 and it’s channels were not correctly configured. Rebooting everything and re-saving configuration to USB seems to have corrected that, but I’ll keep an eye on it.