Emergency loop and screen stuck

Hello everyone,

I had my MCX 8000 repaired ( great service and support by Denon DJ Germany) in May 2019 because of screen freezing twice during gigs. After that everything worked fine. I use my MCX 8000 approx. 2 times a week for gigs in standalone mode (+ 3 hours per gig)

Last night during my gig I encountered a new error. One track was playing on deck 2. I was selecting a new track on deck 1. When I pushed the scroll button to load the track. The screen got stuck with saying: ’ loading’ .
The track that was playing on deck 2 got in an emergency loop and the wave form disappeared. I had to reboot.

I use a Samsung T5 500 GB SSD for playing music in standalone mode for 4 a 5 moths now . No USB stick.

Also worth mentioning. The Samsung T5(500 GB, Fat32) is very fast and worked good. Only the last couple of times it seems that not all new tracks are being transferred from my Engine library to the external HD and also a few track give the error message: unsupported file format. These files are bought on iTunes and 80% of my music files are bought on iTunes and work fine except a few.

Does anyone had the same problems and has a clue if the problem is caused by i 1. the unit, 2. the T5 or 3. a corrupt music file(s).


Engine prime will process more file types than the older MCX8000 - that’s probably why you’re getting “unsupported”

For the freezing on loading, I don’t know.

It could be that the mcx is only usb 2 and all nearly SSDs are usb 3. Have you got anything else pulling usb power off of the mcx ? Mobile phone charger or pretty lights?

Hi Christopia,

Thanks for your reply.

What do you exactly mean. It. worked fine for 4 months in Engine prime.There is nothing changed in file format. Still the same AAC format.

No there’ s nothing else attached to the MCX 8000, but the power cable is attached to a extension cord. Thats also supplies power to the booth monitor and the light controller. I have been dj in the same setting for more than 6 months. I don’t expect that to be the issue.

Best regards,


Could it be that your Engine database on FAT32 is maxed out at 4GB?

Sorry maybe I should have said more earlier.

Some background… imagine that a full prime deck (Sc5000 or prime 4 ) can play 20 different types of music file format, like mp3 or aac or flac or wav etc. But the mcx, which was designed a long time ago, can only play 10 different types of music file.

The mcx used to have it’s own version of Engine, which only processed music files that the mcx could play. But, then things were tweeked so that the new Engine Prime could be used to make mcx libraries. But Engine prime knows more music file types than the old mcx knows. So some music files will work in Engine Prime software, but won’t play on the mcx.

Engine prime does have a “mcx compatibility mode” which should tell you when Engine Prime sees songs which won’t play on an mcx - but that feature can be switched on or off. Maybe your compatibility mode for mcx is off.

If you’ve got those sort of files that mcx won’t play, you can burn them to cd and rip them into a file format than mcx can use, or use a file convert or program to convert such files to mcx recognised formats

My suspicion as well.

He can’t add new music either to the SSD.

FAT32 has a single file limit of 4gb

The Engine DB file increases in size as you Analyse tracks etc I think

1 Like

Hi Christopia,

I have the ’ mcx compatibility mode’. on. The odd thing is that happens to some iTunes files. These are all the same format. I would understand if it was a other format, that some files just are not compatible.

I will do an re-install. Maybe that will work.

Thank you!


Most likely it’s the iTunes DRM (digital rights management).

I don’t think that we are allowed to share info on this forum on how to defeat DRM. If you don’t fear copyright issues then you could google the subject of iTunes DRM

Just in case, check your mp3 with MP3Val to make sure there are no errors on your MP3s

Link: http://mp3val.sourceforge.net/

Also for those unsuported files try fixing them with fre:ac. You can create a batch job with all unsuported files at once. Maybe they are at 48000 MHZ, you can set the LAME encoder on the fre:ac to 44100.

Link: https://www.freac.org/

Both are free tools.


I had the same problem but with engine prime 1.4 beta it doesn’t happen anymore, I hope you solve


1 Like

@DJ Chachi, thank you!

1 Like