Echo Effect Bugged

Hi, I just got my Prime 4 a couple days ago but have already noticed an issue with the echo effect. Not the sweep echo effect but the one in the FX menu. The echo will continue to play after I turn the effect off. It won’t turn off until I either switch effects or completely turn off the fx/wet/dry knob. Is this a known issue is it just my controller being bugged somehow?

Does not sound like an issue, but like a something that has actually sense. Hit echo and switch off for slow fade out. Unless it stays on continuously.

It is staying on continuously. I know that it is suppose to work post fader, which it does fine but I just find it odd that the echo stays on after I deactivate the FX bank

i have had similar - is the feedback up full ?

Yes the feedback is up full but I don’t think that should matter if I deactivate the bank.

it’s just that’s when it happened to me …

@Reese, can You check also that fx?

I haven’t got a Prime4 here anymore. @Addie?

2 Likes

@DJAces Can you provide me your firmware version and build number? And also please the steps (setting/values) to reproduce? I cannot reproduce your exact issue, but it might be a different build

@addie Here is a picture of my firmware version and a video of my issue. It is defiantly not doing what it is suppose to do

1 Like

Thanks for the video. I have installed the same build and here the echo is always echoing out.

The video you posted is too short to determine if the echo continues to echo infinite, despite turned off or if the echo fades slowly away. With the Wet/Dry full open it will take a while before the echo reaches it’s end.

Must be noted that indeed the echo is not killed immediately when On button is switched off, but it will echo out with a fade out.

Yes the echo does eventually fade out. I am totally ok with it echoing out if I leave the FX on and turn off the fader or stop the track but again it just doesn’t make sense to me that the echo would still be working after I turn it off. I feel like the echo should be killed as soon as I turn off the FX.

Thanks for clarifying. I now understand what you expect, but what you experience is expected behaviour and i’ll try to explain why

This effect adds echoes of the original signal. By pressing ON you start adding echoes. When you disable the ON button (so turn it off), you stop adding echoes to the sound, but the echoes that were already added have not suddenly disappeared by stopping the process of adding, but still added to the output sound.

Like when you put balls at the top of a slide and let them roll down. As soon as you stop putting down new balls, those that were already on the slide still roll down.

3 Likes

@addie Ok. I think I get it now. I guess I’m just going to have to get use to how it is suppose to work. Thanks for all the help.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.