DN-F300 Solid State Player Help!

HI! I have a DN-F300 rack mount media player. (USB/SD) The unit is stuck at F/W Recover. When powered up, that’s all you get on the display. There is a service bulletin out regarding this and I followed the instructions to re-install the firmware to no avail. I’ve tried reinstalling the firmware (Two versions) I contacted denon tech support. They sent me the firmware files and after that didn’t resolve, they suggested it was a hardware problem. When you start the firmware update, it’s supposed to erase the previous firmware. It seems that’s not happening. Has anyone had this issue? Any guesses? I can replace it for 200 bucks if I wanted to so I’m probably not sending it out for service. If I kill it trying to fix it, I won’t lose any sleep. Also, does anyone have the service manual? I can’t find one for under 25 bucks.


Hi trooper

Would you send me 2 firmwares you got ? Please upload them to somewhere cloud and let me know the URL.

Actually I have 2 units of DN-F300. One was v-19.33-01 and another one was v-17.24.

We could download firmware file of v-17.30 as latest firm even though it is not latest. I used the firmware file to my both units to make same condition but it was not so simple issue.

The one became to v-19.30-01 ( why? ) and another one became to 17.30 as a result. V19.33 became to V19.30 by V17.30 firm. It’s so strange issue. I would like to make one to 19.33 back right now. However there is no way because I do not have a 19.33-01 firm. If you have it, please give me it. The support never send me call back after I sent message to them.

Anyway/Therefore, I think these 2 units are not same hardware. Technical support should write this information even if it is too much legacy device because they made it.

I don’t know how many types hardwares are there as the DN-F300. Actually 2 types are in my home at least.

I guess you used wrong firmware for your unit. However, the guys never told you the fact. We must do the update because they are saying that is the latest firmware. You should claim it. It may not be your responsibility.


i have the same problem here. The software update that I tried is the v16.20 version. This firmware has no effect during the update. Do you have a different version? can we possibly share this?


hi fwre Your current version is 16.20 right? Did you tried official 17.30 updater ?

Hi Taichee,

No. Where can i find the official 17.30 update?

Can you send me other update’s you have?


This is a link of official v17.30.


I don’t have any others.

Trooper might have somethings.

thanks for the update version v17.30. Unfortunately, this also does not work on my device.

If someone else has another version then I would like to receive it.