Distortion Issues with the MC7000

Is there a Firmware update for the MC7000 and if so how do I do it. Similar issues with the 8000 seems to have been solved with an update. Could it be a similar case for the 7000.

There have been some minor FW updates for the MCX8000 but nothing to do with distortion. It’s generally issues with latency and your PC rather than the controller itself.

Give us more details of your PC it’s specs.

OK I run an Imac 2.9 Ghz with 8 gb Ram i5 with Serato (1.9.10) and an old Macbook pro 10.7.5 cant be upgraded any further but rock solid for music with Serato (1.9.6) plus Windows 8 laptop i5,2.5 Ghz with Serato 1.9.10. Tried all 3 and same result. Sound deteriorates sometimes after an hour or so and sometimes quite quickly. No issues whilst using my MC6000 mkII. Since upgrading to MC7000 haven’t been able to complete a radio show without the sound problem. Quick fix is to turn off and on but this is obviously unsatisfactory. Moved buffer settings without any improvements.

Ah ok. I know absolutely nothing about Mac so someone else may be able to help.

I am having the same issue but I think because I upgraded to high sierra which I regret doing. It was fine before I did the upgrade. I can’t find no FW update for this. I’ve tried audio midi setup but not sure what to do there. I have the 2012 MAC BOOK PRO 10.13.2. Serato.com mentioned it was fully compatible. Please help!! lol.

Hi i rolled back to elcapitan via time machine now i’m all good i suggest you do the same if you have a back up, always back up your data before doing a update…

Hey Val, unfortunately didn’t have El Capitan to begin with. Want to Upgrade to El Cap from Yosemite but Apple does not give you that option. Want you to go straight to High Sierra which I don’t want to do until there is enough positive feedback about High Sierra to make me take the plunge. Probably have to go through Apple Support…

Hi Chris stay away from high sierra for now its been a nightmare for me elcapitans the way to go…

Chris Give me a call got a fix for you :slight :slight_smile:

If you are using Serato AND High Sierra, it seems the only version supporting this combination is 1.9.10 (not the 1.9.6).