Denon Sc5000

Denon Sc 5000 prime I recently update my firmware to 1.4.1 and it says peripheral did not come online during boot now jog display is gone, also link option is not showing I tried to switch back to old firmware And again update 1.4.1 but still nothing happening, there is no logo on jog display, I updated thru computer.

Please help Thanks

Try 1.4.1 again. If it was working, then it should be back online after update. Unless it has a hardware issue, but before jumping in to any assumptions I would try to go with newest update again couple of times to be sure.

Hi mate, thanks for your message unfortunately I tried everything n it’s still same, I wonder how unit could be faulty, it was working fine before I updated new firmware

Oh same person. I just replied on the duplicate posts

call tech support…In the meantime, if It was me, I would try to roll back to the older fw and see if that fixes anything and if it does, try upgrading again but with a fresh download just in case.