Denon mcx8000 broken

Hi, I have a mcx8000. It remains frozen in the loading screen, and only the lights of the screen are turned on (everything else is off) I tried to update the firmware but the utility button does not work and when it worked (before) the wheel to choose the options does not work (neither in the right part nor in the left part) and in demo mode it enters sometimes and each time in a different way. I’m desperate, please help.

Denon MCX8000 Emergency Update Procedure

1.Place a USB drive that contains the latest firmware update package into USB 1.

  1. Power on the MCX8000.
  2. The left deck Cue button will flash. Press the Cue button.
  3. The left deck Sync button will flash. This indicates the unit is updating.
  4. When the left deck Play button is lit solid green the update is complete.
  5. Turn the MCX8000 off, count to 4, then turn it back on again.
1 Like

I try it and it does not blink, the only ones that it has are those of the screen and the one of the buttons of above.

It’s just time to get it repaired. Rarely, some things need more than a reboot or firmware upload

It’s a hardware fault. We had a brand new one for a club install exactly the same and reflashing the firmware in emergency mode or toggling Vegas mode didn’t work.

I’m already desperate, I need to fix it.

You either need to contact your seller or arrange a repair with Denon.

hi @b4n4n04 did you solve the problem? I have the same problem

Hello @Canaris I have same problem with the screen after I tried to upgrade mcx8000 to v2.1. I tried your method but my cue point is not even flashing. Anything else I can try?

Thank you

First, it will be good to know from which firmware version you are trying to update. Also I suppose that your problem occurred when you were trying to update the firmware following the standard update procedure. Denon MCX8000 had several previous firmware versions that received incremental updates over time. Ideally you would want to perform these firmware updates following their release order. Second, I would recommend to run the update package from an empty usb flash drive with sectors and files properly aligned, putting the firmware it the root of the drive. If your usb flash drive encountered a problem it’s possible to lead to firmware installation failure. You can try to run the update from another usb flash drive and hope that the process will continue from were it remained. Verify the downloaded firmware package integrity and if necessary download it again and follow the update procedure carefully. You can find MCX8000 firmware update version history here: https://www.denondj.com/downloads-archives#mcx8000

@Canaris

Thanks for the reply man. To answer your question here’s the detail.

  1. I bought it last September last year and updated to v2.0 if I’m not mistaken.
  2. I follow everything you said but the screens are still frozen and CUE button won’t flash.

You can try this also: hold the vinyl button and switch on the unit. This should activate the demo mode, with all displays and buttons lit up. Afterwards, switch off the unit, wait a couple of seconds, insert usb flash drive in slot 1 and switch on the unit again. Hopefully the update process will resume.