DENON DN-X600 working under Traktor

Hi all,

I want to start using my X600 under a windows 10 with traktor. Whatever I do, can’t get it to work.

First of all can’t find the software for the x600; I have version 1020 and there should be a version 1030. Somebody that can provide me a link?

Secondly I try to get the audio in/out working in traktor. I have no problems doing this with my X1600 but the X600 only shows Left and Right channel and not its 4 stereo lines. I have ASIO drivers from 2011/2016/2017 and 2019… not any work… I changed it from master to channel mode (internal/external) but no results… Anybody can help me?

If I have to switch to windows 7 or a 32 bit version; I can do so, but don’t want to waste so much time doing it… Tips are welcome!

Otherwise: DENON make us a follow up of the X600 model!!

First, install 32-bit Denon DJ Asio driver 2.2.2. and after that the latest version of 64bit Asio4All generic drivers (select those in Traktor audio dropdown menu). Then you’ll be able to select 1/2ch for deck A input and output and 3/4 for deck B.

Also, put 5/6 for deck C output and 7/8 for deck D input (then set deck D for recording). Now you can output third deck using USB snd/rtn button on the mixer and adjusting volume using dry/wet knob.

I got this working on a test with a windows 7 32 bits version, but whatever i try i doesn’t work with my windows 10. Where do I download the 32 bits version of the Denon ASIO driver?

thanks

You didn’t follow my instructions.

You don’t answer my question: Where is the 32bit version of the 2.2.2 Denon Asio driver? Because just installing 2.2.2 and then the asio4all version isn’t working! I tried that…

It is working because i have it running on win10. Denon ASIO 2.2.2 is the 32-bit version so it doesn’t work with 64-bit applications like the Traktor Pro 3 but it is needed to be installed because it gives the windows general information about the X600 interface (that it has 8in/8out channels etc). After you install it, in the Device Manager you will see X600 listed and under MIDI device it will still have one (?) next to it but it will be listed under Audio Devices. ASIO4ALL (since it is 64bit driver) will give you the ability to use it in TP3.

There is no 64-bit Denon ASIO driver for X600, there is only for X1600 and X1700.

Strange; I installed it the same with the 2 drivers, but don’t see the 8 channels.