Deck 2 Freezing on Prime 4

I am having a major issue with Deck 2 and 4 on my prime4, this problem has been evident from the time I received it (late June 2019). When I play tracks in continuous mode and it will eventually get stuck after a short period of time, anything between 5 and 45 minutes. The screen for deck 2 also freezes. When you attempt to resume the track on deck 2 with the play/pause button it does not affect the track but the LED will switch from solid to blinking and back again, even trying to load a new track makes no difference and the only way to resolve the problem is too power down the prime 4 completely. Even if I switch to deck 4 I have the same issue. After a few weeks I noticed I wasn’t alone with this frustrating problem, other DJ’s were experiencing the same problem. I monitored Forums and hoped a firmware update would resolve the problem. I always update my Prime 4 to the latest Firmware and have even switched back to an older firmware (from advice) and this still makes no difference at all. As you can imagine this is very frustrating as I use my controller for private parties and like to record DJ sessions at home. If I was using it for weddings etc it would not be fit for purpose as I have no trust in it to perform. On average I have to reboot the prime4 nine out of ten times during normal use. Decks 1 and 3 have no issues at all to date.

Further to this issue, over the last few days I have noticed a further problem, deck 2 is now freezing / jumping whilst playing tracks, as you can imagine this is not ideal whilst in the mix.

For your information I have followed everyones advice, removed the clear plastic from the platters, tried using various USB drives, I have updated firmware, I have grounded myself and discharged any static energy, I have moved the controller to different rooms in my house (warm/cold away from heat sources etc), I also installed a Samsung solid state hard disk with loaded music. Nothing has made any difference.

Any advice people?

Also tried logging a request to Denon, but being in the UK, the website doesn’t like my address and keeps asking for STATE… Not a happy bunny now…

This has been reported by other users too. There’s also the problem with peripherals not loading.

Hope this unit isn’t going to have major hardware issues like the MCX8000 before it.

1 Like

Hi @Boyceduke - As discussed in our PM, I’ve sent your contact details to our UK team to reach out to you directly to assist further.