Cue Mix not isolating

#1

Anyone have an issue where the headphone cue is not isolated when going all the way to the cue side? Master is bleeding in, and I am not sure why.

1 Like
#2

Hello;

I had the same problem with my first x1800.

I returned it to the store and they send it of to denon for repar.

The store gave me a choise either a full refund or a new mixer

I chose for

2 Likes
#3

I ended up doing the same thing. I bought a returned item from Amazon (Warehouse Deals) and the pot seemed to be broken.

#4

31 December 2018

Today I was using my x1800 mixer and my headphone cue was not fully isolating my cue side and the master was still bleeding in. A simple Turn off and turn back on helped. I am a bit worried this may happen during a live performance.

#5

is your fx cue on? mine will bleed over if it is, even if the knob is turned down.

2 Likes
#6

I imdid this exact thing on Saturday, and was frustrated as hell for about 10 mins!!

#7

Yes. It was the FX Cue. They need to fix this…

#8

Hi all,

Sorry to hear you are experiencing this, as with anything that behaves like it should not, please contact our customer support team who will be more than happy to assist you: https://www.denondj.com/support

Regards, J

#9

I did some testing on my 2 X1800’s.

They both have this problem.

When you turn on the fx que, the master signal bleeds over the que signal.

However It’s not with every effect you select, echo, delay, pingpong, trans, flanger, filter, phaser, bitcrush, roll, revroll, beatbreak, scratch, sndrtn have this flaw

When you select hailecho or reverb, the signal does get isolated until you activate the BPM FX ON/OFF button.

Restarting the x1800 didn’t help for me, the problem stays.

Maybe this is a firmware issue, since both mixers are on fw 1.1.1.

I hope Denon will look into this, or at least ask @laidbackluke if he is having this problem too. Because I saw in one of his videos that he leaves the effects select allways on the master channel.

1 Like
#10

Denon knows about this problem for quite some time now.

And I think it’s with all X1800’s on 1.1.1

Just asking, if this is going to be fixed in v1.2 that will be released soon?

#11

I Just installed. Firmware 1.2

The problem is not fixed -:frowning: