Connect your X1800 with Pioneer RMX-1000

#1

Ok so i have a new 2019 Denon X1800 and a new RMX-1000 both are fully updated.

So here is the set up to connect a RMX 1000 to your Denon X1800: connect 4 1/4 cables to your Denon send and return. The Send cables go to the RMX input, the return cables from your Denon go to the output of the RMX. On the Mixer (X1800) go to your Utility settings/advanced audio/FX return enter. RMX says to set this at -10 don’t because it turns the Vol. way down on your signal. I set it +10 and it was close to my regular setting. Now exit the utility and turn on your BPM FX button on your X1800 and turn it all the way up 100% wet. Some say 10 o’clock but this is the volume control now for the RMX, and if you want to hear it and use all of its function you must turn up the Dry/Wet 100% or it gets washed out totally. The dry/wet is like the vol for your X1800 or (dry), And the Vol. for your RMX (Wet). Last thing some of us play in stereo I have the Bose F1 system and play in Stereo on the X1800. The RMX is a Mono based device and you need to change your button at the top of your mixer to Mono or you will only have one channel. Once this is done your RMX 1000 should work perfectly and completely.

1 Like
#2

Hi @Tshradio, I have passed this on to the product team and hope to get you an answer back ASAP.

Thanks J

#3

Thanks Jay but this is the only way i found after reading the forums, and facebook to get it to work. This is what i did to connect the RMX 1000 to the Denon X1800 and it works perfectly. Did you read the post or just skim through it? lol I posted it to help others make the connection because it is an obvious problem.

#4

Seems to be a shame to throw the whole sound system into mono just to please the fx box.

Couldn’t a splitter cable be tried from the fx box output to feed into the left and right returns on the mixer?

2 Likes
#5

Apologies @Tshradio, I didn’t read it thoroughly and went into ‘let’s get this problem fixed’ mode a little too quickly!

Fantastic you are offering solutions on the forum, something we love and strive for!

Thanks, J

1 Like
#6

excellent, just yesterday I disassembled the RMX1000 from the DJM900 and installed it in the Denon1800. Having little time, I could not fully test, for I had seen that I had signal in the RMX, but I had no signal output from the mixer. I was documenting on the manual, but first I wanted to see on the forum if they talked about it … and here is the answer. Thank you tonight I try to give you my feedback as well.

2 Likes
#7

Hi, I tried to follow your instructions step by step, but the RMX doesn’t work. What can I do? Is the connection set to -10 or + 4db in the back of the RMX? I have it at -10

#8

Set it to -10 but you also need to change the setting on the X1800 On the Mixer (X1800) go to your Utility settings/advanced audio/FX return enter. Change it to +10 and check your cables. Also you can switch your mixer back to Stereo if your cables are good the stereo settings will work.

#9

I will definitely try again, but I’m almost sure I did everything step by step … but as soon as I turned the effect on the mixer and turned the knob to 100% wet, it only processed the mixer effect. I must also say though, that in the RMX if I activated the effect, I could see from the vu-meter that the output signal was processed, but it was blocked by something inside the mixer itself, so I couldn’t hear it.

#10

What do you mean by that? Which mixer effect? Please make sure that you have the effect frequency knob in the X1800 in the middle position (all frequencies), and that you have selected the SND/RTN effect in the X1800… Then it should work.

#11

Did you remember to select snd/rtn as your FX on the mixer? Once you select this for the FX on the mixer your telling the X1800 to send to the RMX 100% VOL and FX.

#12

Huh? The RMX 1000 is stereo device that can be made to run in mono.

1 Like
#13

yes you are correct i just had some bad cables. And i stated as such somewhere here in the forum that you can run in stereo. Thanks!

#14

I reinstalled everything, including RMX, redone the steps … well, everything works now.

1 Like
#15

Awesome news. Enjoy it bro!

1 Like