[CONFIRMED] Tracks in Length Greater Than 20 Minutes Fail to Sort by Time

Hi @addie, to sort by track length simply press the button next to SORT BY (in library view) and then select LENGTH

Thank you

Hi @Jay_DenonDJ, the result in the video is sorted by length

Does it still show this even if you toggle the arrow for ascending/descending?

Also does this happen on all playlists?

Thanks

@Jay_DenonDJ Yes it does even after toggle for a few times. I just checked in Engine Prime instead of Prime 4, and it also happens in Engine Prime. It seems that it occurs with tracks longer than 20 minutes (extremely long versions or mixes). Everything under 20 minutes seems well sorted.

Ok let me flag with the dev team to investigate.

Hi @addie, just to update you the dev team are looking into this and I’ll update when I know more.

Regards J

1 Like

Hi @addie ,

Thanks for reporting. We have confirmed the behavior on our side. Currently, we have higher priority tasks but will look into this when time and scheduling allows.

[Locking thread until resolved, no further detail or comments are necessary]