BPM recalculation when play song on dj console prime 4

Hi All,

Can somebody support me? All my tracks are auto analysed on my pc with engine prime program In 99% this BPM setting is after this analyze ok. When I export to my prime console, these BPM’s are correct copied. So normal the console does not have to recalulate the track. In 10% of my songs (mostly retro with high BPM’s 135 - 155), the prime console is recalculating and then sets a BPM of 70 - 100. This is really frustrating me…

Can I disable the recalculating on my prime console? Anyone tips? Many thanks in advance

what format is the prime 4 drive? exfat or fat32?

I checked, it is EXFAT.

What about the music source drive exfat or fat32 or NTFS or AFPS? is it internal or external?

and are those tracks wav, mp3 or flac?

copy from internal NTFS drive all mp3 files

Those tracks that are analysed again when you load them to prime4, is there a dot in the grid column in engine prime?

No dot. One difference I found now is that when the console re-analyzed a track and he changed it to lower BPM, which is not good, that I can change it to the correct BPM. I have to re-import the tracks with pc and than he keeps the correct BPM… but this means that prime console need to analyze first track by track and than after this is done, I can re-import from PC with correct BPM. You know what I mean?

Oh boy…

no dot means its not analysed in engine prime yet and thats why the prime 4 is analysing again. you can select the bpm range to aid the process. if you are doing hig bpm tracks select a high range. same applies to engine prime

sort your engine prime library by the grid column and analyse the ones without the dot

First of all, thank you for supporting me !!

I’m sorry, I misunderstood the dot remark. I checked on my pc and all mp3’s have dots. I thought you mean on the console I had to see a dot when he starts analysing.

So in the program, everything is analyzid. On the console for playing, he is re-analysing for some mp3’s (not all), if he re-analysis, he is changing in most cases BPM from 140 tot 139,4 for example. But in rare cases he changes the BPM to 70 or 90 and this is unworkable…

Kind regards

If there is a dot on the tracks in Engine Prime and the prime 4 is still recalculating then you may have a database issue in engine prime using either of the following method.

remove the USB drive.

1. Zipped Folder Method

Back up your collection by zipping your system’s Music \ Engine Library folder. This is where your system collection is stored.

2. Rename Folder Method (Creates a new collection)

  • Rename the current “C \ Music \ Engine Library” folder to "Engine Library (OLD)"

After doing either, start engine prime again, it will be empty, now add all your files from the MUSIC folder and use REANALYSE. I will also recommend that you have autoanalysis disabled in EP settings

Ok, I will do. I’ll keep you informed about the result. Thanks again.

1 Like