BPM on the master setting

With engine connect on and the BPM on the master setting doesn’t seem to work correctly, if I choose the deck individually it picks up the correct BPMs via the engine link but using master it seems to only pick up the same deck all the time.

The way this worked on my old DJM2000 on master was whichever track was loudest via the xfader or faders it used that BPM, the X1800 just seems to only read it from one deck on the master setting regardless of autosync or faders, as I output the midi to lightning software via USB this causes issues.

Is this the same for anyone else, im pretty sure its a bug?

For the deck you have issues with, (on the mixer) switch your RCA cables from current channel to the other of the same pairing. (So either 3 to 4 and 4 to 3 or 1 to 2 and 2 to 1)

If it’s your deck1: Remember that Layer A (1A) is CH1 and layer B (1B) should be CH2. If it’s your deck 2: Remember that Layer A (2A) is CH3 and layer B (2B) should be CH4.

My eth cables are in port 1 for deck 1 and port 3 for deck 2.

This should fix your issue.