Blue light is not showing when usb is plugged in

I bought the Denon DS1 on the 11th of this month . I probably played with it a handful of times . For some reason when you plug in the interface to usb the light doesn’t show up and does not connect to serato ? Any reason for this ? I have searched hi and low but nothing on this topic ?

Since it worked before, something has apparently changed. It could be the unit having a problem or the port you use on your laptop/computer.

Have you tried another USB-port? Or you could try any old USB-adapter (like the one you use for charging your iPhone). Effectively anything that give the proper amount of USB-power should make the light come on.

If not, it might be a faulty unit. In which case I’d say follow the warranty instructions.

Hi @Sean, thank you for your post and sorry you are experiencing this problem.

Here are a few tips to try, I’m sure you have done some but just to be thorough:

  • Reboot laptop
  • Ensure the latest Serato is installed
  • Try different ports
  • Try different laptop/pc (if possible)
  • Try different USB cables

If after all of these your DS1 is still not functioning as expected please contact customer support: https://www.denondj.com/support

Regards Jay

Thanks for the response fellas I just got the RMA from denon and took it to guitar center and switched it out. I hooked up the new one and I am not being paranoid but the sound doesn’t compare to the quality of the one that broke. I haven’t Had enough time to go through it yet but it definitely sounds sub par to my Mac Pro sound card. I am praying that I don’t have a back to back issue .

Thanks