Alternate Download link for Engine Prime Version 1.2

Hello guys, i am having issues downloading 1.2 ver of engine prime. i get the error “forbidden” with any laptop or device i try on. can someone please email me a .dmg file for it on .

kind regards, Ankeet Modi

It’s working for me on mobile browser, try clearing your cookies. I posted a link to the official download link but post is being moderated.

It’s working for me. Try clearing your cookies

I have tried everything… From resetting cookies to clearing all history etc… but all I get is error 403- forbidden. Could you please email me the .dmg setup file please or use wetransfer. For some reason the website downloads don’t work in East Africa

no prob AdjModi: /file /hVkxQtp

remove the spaces from the url. seems to get filtered or so otherwise.

thank you soo much!!! you are a legend :smiley: :smiley:

This does not work?

just to make sure that the original download is the problem indeed try the direct link:

Hopefully this link above works but if any of you have further issues please let us know :slight_smile:

exists a direct link to Version 1.2.1 ?

1 Like

I cant download engine prime for windows too! ■■■■■. 3 months down the line after buying the mcx8000… your support team does not even respond! I Don’t understand why i get that error 403 Forbidden

This doesn’t work? What browser are you using? Try a different browser.


Nothing seems to work, I am using Chrome browser, Avg browser same thing

You’re trying to download from a Windows computer, not a Chromebook?

Yes am using a Windows browser

but why is it so difficult to download this particular setup? i have not faced similar challenges with other softwares before. even after registering the device same problem! how i wish i got a pioneer instead tbh. These are the kind of frustrations i hate to be experiencing now. Simple user interface

It’s not. Links all work here, so it must be something at your end of the internet.

Ditto. Just tried the AVG browser and the file downloaded without issue.

Can you not get a computer savvy friend or colleague to help you?

Try downloading it from another computer.

so it seems you have restricted some geographical areas!!! my friend tried from his laptop and got same error so he had to use a server from denmark for it to work! This is quite limiting. i have seen that someone else from East Africa posted a similar concern. I do not see as to why this problem even exists