All music from a single Beatport link playlist will no longer load

A beatport link playlist that was playing fine on beta 1.6 will no longer allow me to load any track. Even if I search for the playlist track outside of the playlist, it still will not load.

  • Engine OS Device: SC6000 & SC6000M

  • Beta Version: 1.6

  • Steps to Reproduce:

  1. Connect to Beatport Link
  2. browse to the playlist
  3. select any track
  4. existing track remains with no error or message.
  • Expected Result: Track loads and can be played

  • Actual Result: Inability to load any track from the playlist.

  • Reproducibility: Everytime

  • Additional Notes:

  • Link to Video Repro:

What is the exact message that appears when you try to load a track?

Do the tracks load and play via the Beatport Link web site, or DJ software (which has Beatport access) on your computer?

No error or message appears, the loading track briefly appears but disappears immediately and the track does not load.

Tracks play via web interface and in djay pro software. They were playing on the denons until yesterday when they stopped working. All other beatport tracks load, as long as they are not in this playlist.

Did you create the playlist yourself or is it one supplied by Beatport?

If its the same as on prime 4 it’s your own playlists. Doesn’t happen on all playlist though. The track seems to load but just isn’t there. Just blanked out in the player but in the top waveform the previous track name still remains. I and others have also reported this bug and its under review.

I created it. I’d been playing with the list for a few sessions so I would have saved some hot cues, loops etc.

I thought it might be related to saved data on the drive but I just tried a seperate clean USB with the same results.

I also noted 2 other beatport tracks in seperate playlists do the same thing this morning, so the issue is no longer isolated to a single playlist, although that’s where the issue began or I first noticed it.

Some little update of mine: For around last two weeks everything worked perfect for me regarding Beatport Link. All tracks loaded up as excepted - so if you fixed that issue - thank you!

I rolled back to 1.5.2 on my SC6000M and 1.5.3 on my SC6000 and that fixed the issue with this playlist. All tracks that I could not load now work as normal.

However, all seemed good for a while (2-3 hours) but I have started getting the same problem with new tracks in the top 100 genre playlists. seems fairly random, some load, some don’t, exactly the same symptoms.

Its a strange bug, the roll back seemed to have an effect but the fact that I am now getting the same problem with new tracks mean something else is going on. Hoping Denon can get this sorted quickly.

1 Like