4 decks and control usb

Hey guys, wondering who has 4 deck units and running a single usb as control?

What I mean is are I using one usb on a single deck to be the main drive for saving your settings and any cue points off Beatport/tidal and etc. or are you running individual usb to each!

Just went to two 5000m’s and two 6000’s

Choose the deck with the physical drive as the source for all decks.

That’s what I planned Reece. Hoping without internal drive in that they don’t freeze/lockup this time. Still need to install ssd drive in a 6000

That doesn’t matter. On my 5000’s I’ve always used an external ssd. Still do on my 6000’s, but will become an internal ssd. On Prime4 and Prime2 I’ve always used an internal ssd. All devices share sources.

I had all four on and i have one drive as source for 2 and another drive as source for the the right two. Seems if I use the 6000 as source with three different brand usb I get some problem. This time it was no hot keys. Going to try and just run WiFi. However same usb had no issue until I added the 6000s.

Use wired network. WiFi cannot be used to share Engine Connect info. Use a good brand USB drive (SanDisk, Samsung).

WiFi is for beatport and tidal only. Using scan disk USB’s.

Update @Reese did a set and live and two decks went out and had to restart 3 times. Ok. Update here. Did a reload and still getting some issues on two decks of of four. It’s freezing, loss of hot cue controls, drifting and bpm control. Then I had to hit sync to get it back and after deck wouldn’t respond.

I had no usbs connected only using tidal after 20 minutes in. It’s like the problems are jumping all over the place when I start selecting tracks.

You have all four decks on single layer mode, I hope? And you’ll always need to choose a source drive for streaming.

Yes sir. I tried it both ways. With usb it happens with all three brands I have. Without usb it took 20 minutes before they dropped out

I will say the problems affected the two on the right. The left decks a 5000 and 6000 had no issues.

I presume you have a X18x0 mixer with 4 separate ethernet cables to the decks?

I have the x1850. I thought maybe it was the problem. It froze once with a mic but the 1800 before it was flawless. Had the 1850 since it was released. 4 separate cables.

Could be the mixer. Press and Hold the Engine Connect button (should be ON btw), what do you see on all decks?

I get engine connect with all decks assigned in order as I picked them for layer A. For layer B the none is lit up for all!

What if you swap units left and right. Does the problem stay on the right?

Another thing you could try is a separate network switch, but you’ll lose some Engine Connect info like cue color and perhaps bpm.

I will give it a try. I was having problems on all 4 but after reload of software the problem occurred once for a deck on left. I plan on trying the following:

  1. Going to back to just the two 5000m and the x1850.

If no problem

  1. Add one 6000

If problem swap network cable. Continue and check

If no problem

  1. Add the second 6000. If problem check network cable and swap.


Try running

1a. Only the two 6000 with x1850 and try to replicate error

1b. Run only one 6000 and 5000m together.

1c. Try Netgear switch as hub for units or no network of all four units and run as standalone with usb or WiFi for source music!

I will try to narrow down if it is the units, cables or maybe the x1850 that is having issue.

Note. These are issues outside of the drift on bpm and vinyl mode issues that others are having that I’m seeing now.

Note2. Maybe even try reloading software with a usb instead of Mac to each unit.

@Reese anyway to downgrade firmware on x1850?

I let you know over next few days. Depending on what happens the sc6000s could go back. Problems occurred when they were added to setup.

Okay. Rules of elimination indeed.

I don’t have experience with the X1850 and its firmware.

If I really find the time and space I’ll try my X1800 with two 5000’s and two 6000’s.

Yep. I will also be doing a cable test for all network cables. Maybe up them to cat6.

I wondering if many of the problems are the x1850 causing them?!



  1. Turned on all players. I turned a 5000 and 6000 at same time and 6000 takes much much longer than the 5000.

  2. Powered them all down. Then I disconnected cat5s or network cables for the 5000s from x1850. Turn on mixer and 6000 players. Then changed settings for the two and used one of my newer usb. Getting same errors. I then powered down and tried an older usb. Same issues but took longer to develop.

Trying the other options later.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.