2.0 bricked - hardware reset?

2.0 firmware bricked my device, powers up but screens stay on denon logo and can access menu to roll back.

is there a way to hardware reset with buttons at power on?

Try holding the left vinyl button when powering on. The unit should go into a demo mode. The screens should have the features of the unit displayed and the vu led’s should be running up & down etc. Now power off & on again as normal. This worked for me when my unit was stuck on the denon logo. But it also hasn’t worked for everyone, so it’s only a 50/50 chance, but it’s worth a shot.


this did the trick! exactly what I was looking for and couldn’t see it anywhere. had tried a bunch of different button combos.

Thanks so much, back in action!

Awesome!! When this first happened to me, I went almost a whole week trying to reboot & hoping it would come right. Then I read somewhere about putting the unit into “Vegas Mode” & thought, this just might be a way to reset the displays. I tried it and… it worked!! A couple of others have tried my suggestion & said it didn’t work though, so I’m really glad to hear this worked for you & you’re back in action. The real crazy part of this story is that since I did this, it’s never frozen on the logo again…touch wood!!

1 Like

Denon support got back today with this, which may be of use in the future;

Denon MCX8000 Emergency Update Procedure

1.Place a USB drive that contains the latest firmware update package into USB 1.

  1. Power on the MCX8000.

  2. The left deck Cue button will flash. Press the Cue button.

  3. The left deck Sync button will flash. This indicates the unit is updating.

  4. When the left deck Play button is lit solid green the update is complete.

  5. Turn the MCX8000 off, count to 4, then turn it back on again.

1 Like

Very useful info. Thanks for sharing. Denon - You should make this type of info readily available in the troubleshooting area for the 8000 for easy access to all.

back on this problem again, only I can play with serato but can’t access standalone menus to rollback firmware or change settings. previous to this after first fix above i had menu access and set screen brightness to lowest.

1 Like

Hi @kboogie, i have the same problem. Did you solve?