When Select/Load Knob is triggerd tracklist always moves to Full/Bigger Playlist..


#1

Hi All,

Upgraded my MC 6000 Mk1 to MC7000. This is what I call…AN UPGRADE! What a tool!

There’s just one minor thing that I encounterd and seems I cannot change/Haven’t found it it the manual…

Whenever I want to scroll trough my playlist, or select the one next number from playlist in Traktor Pro (2.11.2) it shows the “bigger” playlist…so it changes from Seeing decks and half of the playlist to “bigger” playlist and without the decks…It’s not that big problem but on the MC6000 mk1 this wasn’t the case…if I wanted to see the whole/“bigger” playlist I pushed the browse Button, and could scroll through the “bigger” listed playlist, pushed it again to get back to half playlist and decks…for me this is convenient…

Now even If i turn the Select/Load knob by 1, the playlist changes to the “bigger” playlist…is there a way to decide myself I want to see the " bigger" playlist…and just see my decks/and half of the playlist.? Dont want to push the “Back” Butto everytime I scroll troug my playlist to see the decks and half playlist again.

PS Im not scrolling trough my folders/files etc, I only work with playlist

Cheers!


#2

It’s just the way the mapping was made for MC7000 and Traktor. Watch some tutorials about mapping controls in Traktor and change it yourself however you want, that’s one of the main advantages of using Traktor over Serato.


#3

thanks for reply Slay, hmmm tutorials.:weary:…already checked the mappings and don’t know where to start…so much settings…don’t know where to look for this "knob "because I see more “knob’s” assigned…but you’re right…gotta look for the tut’s…I also found out that holding shift while turning the select/load knob ,the playlist remains the same, the “bigger” playlist doesn’t show…but the songs are now selected on every 5th or 6th song,

Gr


#4

I got it sussed, let me know if u still have this issue u want to fix.


#5

Ohh yess please! :sunglasses:


#6

Sorry for the late reply, busy week at work. Ok, so firstly make sure u back up your settings and mappings before u start messing with anything, that way u can roll it back if something goes wrong and everything starts behaving funky!

Go to :

  • settings - controller manager at the top select the MC7000.MIXER.LIBRARY.FX mapping from the drop down menu.

In the table located below find in the - control list the function that is called only browser on, and select that line by clicking on it. Look further down at the device mapping section for that command and click the button that reads reset.

That’s it, this should turn off the browser mod and your good to go, if this works and u like it and don’t plan on ever using the browser mod how it was originally mapped u can go ahead and delete the only browser on command from the list completely.

Hope this works for u and helps u in some way!

Edit: yeah don’t do this guys, I wasn’t at my computer when I wrote this and got a few things mixed up, been doing alot of mapping the last few weeks and everything is starting to bleed into each other in my mind…I will write up a detailed update with the correct mapping commands to actually get the function as required asap.


#7

OK! Just quickly while I have a few minutes, this function is all tied into modifier 8 in the library mapping. As a temporary fix/workaround until I have the button names and functions correctly referenced for myself I did the following…

I don’t remember which one I changed but I will confirm once I go through my notes however, refer to the attached screenshot…the command that triggers the large browser window is the selected/expand on one of these, I simply changed the modifier conditions on the left and right encoders to the opposite of what they were. If m8=0 I changed it to m8=1 and vice versa, this stops the browser encoders from recognising the modifier 8 browser mod and let’s u scroll through your tracks in the track deck screen.

Have a look at your settings and see which ones are the opposite of the ones in my screenshot. Sorry for the rushed and completely rubbish information earlier, I will try to confirm all of this later and actually post a step by step for anyone’s future use!


#8

FORGET everything I have said above.sorry, sleep deprivation and a serious flaw in my midi mappings were throwing everything into turmoil and I got it wrong. The fix for the big browser issue goes as follows:

  1. Go to preferences
  2. Go to controller manager
  3. Select the mapping for MC7000.MIXER.LIBRARY.FX from the device drop down menu.
  4. Look in the assignment table for this mapping, search the control column for the following command.
  5. only browser on if you have the command list sorted alphabetically you will notice that there is more than one.
  6. Find the one highlighted in the new screenshot I have uploaded, you will notice this encoder “knob” is mapped as a button and click on it to select it, this is the culprit for the headache material :stuck_out_tongue_winking_eye: and this is the one that is turning on the large browser screen.
  7. Go down to the device mapping section for this command towards the bottom of the screen.
  8. Click reset, your done close the settings, it will auto save. You can delete the whole command if u wish to remove it completely.
  9. ENJOY! happy mixing, note the large browser window can still be turned on simply, by pressing the back button on your controller, everything else should function the same. Cheer’s, hope it helps someone :wink:

#9

Paradoxical…YOU ARE THE MAN!!:sunglasses::sunglasses: I never would have figured that out! this is the setting! and yes, works on both decks. also the back brings it back to the “full” playlist!

Im telling you! very glad! thank you for the “headaches” :wink:

Cheers!


#10

No worries :v:

I am very glad that all my time messing around on that helped out people other than myself, I’ll let you know if I discover anything else that is worth sharing which can make our life easier!

Cheer’s :man_dancing: