Two identical Controller behave different. Firmware problem?


#1

I have two identical DN MC 6000. The last one I bought used, almost new. All adjustments are identical but the “new” one behaves different. Channel 1 does not work in midi mode. It does not work with line one but it works with line two??? And it is not only the line fader that does not work, it is the equalizer too. Channel 2 to 4 behave normal. I suppose it is a firmware problem. Is DN-MC6000_v1.012 the latest update? Are there newer ones? Other reasons for that phenomenon? I am using a Mac and Mixvibes Cross. Works perfect since years. That is the reason why I bought a second MC6000Mk1 Thanks in advance to the members here


#2

Generally, the firmware either works 100% or 0%. If the unit powers up, runs through its power up lighting sequences and lets ANY music pass through it, then every bit and byte of the firmware is most likely perfect.

I would suspect the input selector at the top of channel 1. The one where you choose whether the channel is to be a MIDI or an audio channel etc. If that switch isnt making contact with the midi option, the channel wont respond to midi commands. Does the channel work if you feed real audio into it?


#3

One of my friends had exactly this issue last week but on the MC6000mk2. We never managed to resolve it even after reloading newer firmware.

One thing to try on the MK1 is to reassign the midi channels by hitting shift+browse. If you hit certain combinations of shift plus those middle buttons it can cause strange things to happen.


#4

Also check the switches on the back for Mac/PC and Int/Ext mix to see they are in the correct place.


#5

kradcliffe, I tried. First shift and browse. Nothing happened only both cue1 buttons were lighted. Then I tried shift and browse. The software asked me if I want to switch in 2 players mode. I confirmed and killed all midi signals. Apparently the controller is not sending any midi signal anymore. dead :frowning: Thanks god I have my old one because I have three gigs this weekend. Any ideas? Thank you


#6

Shift+browse sets midi channels at 1-4 which it should be.

Try again and reboot the controller before starting your software


#7

The Shift Browse/Sample/Record etc options only worked on the entire controller for its MIDI channel. As channels 2,3 & 4 all worked and sent MIDI which the computer was able to receive then the Shift Browse wasnt the root cause.

If the selector switch at the top of the suspect channel is OK and doesnt feel stiffer/looser/disconnected etc compared to the other selector switches, then it could still be faulty or indeed something deeper inside the mixer relating to MIDI control could be in need of attention.


#8

Thanks to you. I already talked to the service…


#9

Hello. Was this issue ever resolved? Did you get your channels working again? I originally had all my channels working, then I had 3 of my 4 channels working. Restarted to see if it would fix the 4th channel, but instead now 3 AND 4 aren’t working. My 6000 is barely used and in pristine condition, so Im hoping to get these working again. Thanks!


#10

heads up incase anyone else in the future is having similar issues…I wrote to Denon support and they immediately suggested brining in for repairs. Nothing other suggestions were provided, so probably not worth wasting your time contacting them especially for legacy products.

That being said, I was oddly able to get both channels sending MIDI again by ‘playing’ with every knob, fader or button on the channel, and lucky enough, adjusting the LEVEL knob (directly below the Line selection) knob on the channel.

For Channel 4, if I raised the level above 50% the whole channel loses the ability to send MIDI. I then have to lower the Level knob below 10% to get the entire channel working again and then I can slowly raise it back up to 49ish% and the channel will remain engaged for sending MIDI as long as I do not raise that knob any higher. If I do raise it over that threshold and it stops sending MIDI again, I have to repeat the steps above, and lower it back down below 10% and raise again.

Channel 3 was slightly different. I just moved the LEVEL knob back and forth a few times and the whole channel worked fine regardless if I went over 50% gain. If it goes out again, I will just play with that knob until it engages again.

As long as I got them working and didnt mess with those knobs, it worked flawlessly in controller mode.

As suggested by Denon, probably needs repairs on the internals, but considering this isn’t isolated to just me having this issue (I seen other posts on the internet as well), and my item is in new condition, barely used, always stored in a Pelican case and never dropped or abused…I’m going to assume this is an internal design issue.

Its 2018 and this is still a decently compact and solid controller that I love. I dont have anything against updating to a newer model, however, anything in comparison with similar features is enormous in size, which does not work for me.

If anyone else is having the same issue, try adjusting your knobs while using some sort of MIDI monitor to see if you can get any results. It worked for me and hopefully will work for you.