TSP 2.6.8/sc3900/x1700/not working


#1

I can’t get my x1700 to function with DVS and I’ve run out of ideas. I followed this guide which is the only guide I’ve managed to find, but nothing works as it should. Long story short; I can get the sc3900’s to calibrate fine, but although the track is playing on screen the time code signal is coming out of the speakers. If I switch that channel from Line to USB then I can play the track from Traktor but not with DVS via the sc3900.

Traktor version 2.6.8, ASIO is 32bit v2.22. I would attach some pics but the forum won’t let me, so all I can say is that the channels are setup precisely as in the above linked guide, one point perhaps worth mentioning is that on the Audio Setup menu in Traktor in the Phono/Line section where it says Input Channel it also says “not supported”.

If anyone can point out exactly where I’m being stupid with this I would appreciate it.


#2

I’m not sure if the x1700 is still supported in the actual OS ?


#3

Do you have a Traktor Scratch Pro license, or just Traktor Pro?


#4

He’s a win, not a mac user (I assume you though about Sierra and High Sierra OS).

Stazbumpa, did you set your mixer’s DVS settings in the utility? Switched from phono to line?

Usually I strongly discurage this kind of troubleshooting (connect everything then wonder what’s not working). Start with timecode CD’s and make sure the mixer works. Then switch the players to hybrid midi mode and configure them (midi mappings and traktor).

You could be wondering what’s wrong with the mixer while all the time you had the wrong timecode frequency selected for example (only after version 2.7.x Traktor works again with mk1 and mk2 timecode).


#5

I started out with this problem: Pasted from convention on Denon DJ(Unoffical). I too use both dn-x1700 and sc3900. Right now I’m just using MK2 traktor time code cd’s. Then I will attack the midi, but want this fixed first. I can get the signal to traktor but sound is either too fast or too slow. What setting is not set right in mixer or traktor? I find things for dn-x1600 but the two are slightly different, so it only helps up to a point. Why does it seem like people just skipped past the 1700? I set up the 1700 per the 1600 setup for traktor. And that is what I got from that. It would say calibrate fail, but still play the song, just too fast or too slow. I removed the two 1700 tsi files and the 3900 tsi file. Then re pasted back to settings file. I also went here https://noterepeat.com/.../599-denon-dj-hardware-setup-in… Even tho different version I think this helped. I install Asio4All, set it up, but in the end didn’t select it in traktor. So, not sure if I needed to install it. I ended up using the Denon Asio. I did import the 1700 tsi file in Controller Manager. Ran the wizard selected 1700 as my controller. two decks scratch. Then closed out traktor and restarted. I then had traktor scratch default and generic device to select from. Back to perfect time code like using the audio 6, I was trying to break free from. Now, I think I’m going to take a break, before attacking the midi part for the 3900’s.