Troubles with Doubles


#1

So I’ve been using my lovely sc5000 Primes unit and still having the problems with the pitch Fader not reconnecting with the pitch percent number. It seems to have many lots of things that have to be happening for the problem to show, one thing seem to be whether the master deck is still playing or has gone to cue. If master deck is cue then other deck starts responding to it own pitch Fader then.

But, the new firmware has brought in an other issue for me. Remember that Wheb I get stuck with the pitch Fader then I am trying all sort of button presses to get control of the pitch Fader again.

So, master deck is playing to speakers, I load another track to the other deck, cue it up, can’t use pitch Fader so press various things.

What is ANNOYING FIRMWARE beyond my beliefs is that it’s WAY too easy to activate Instant Doubles, a gimmick I’ll never use. But a double press of SYNC and Bang! The track I carefully found and loaded and analysed and cued is then GONE !!! taking me valuable times to re-find, re-load, re-cue, re-pitch.

Could a new firmware offer a tiny option in the utilities/preferences for Instant Doubles on/off please?


#4

What you’re describing with the pitch faders doesn’t sound like an issue, it sounds like it is working exactly as intended. If you have sync on (which you must if there is a deck showing master track) the pitch fader on the master track is the only one that will work. It adjusts all decks. When a new track becomes master, its pitch fader will take over and now control all decks.