Traktor Scratch with DN-X1600


#1

The DN-X1600 used to work fine with Traktor Pro 2 soft but suddenly, probably because of Traktor update, I could not use timecode anymore. So I renewed Traktor once more to v 2.11 and found out that the 32 bit version is not available anymore. So I set it up with Asio4All as http://denondj.com/kb/article/1858#asio4all is guided. I have the sound on all channels as expected but Scratch is disabled, is there a solution?


#2

You might wanna try this: http://djchadg.com/videos


#3

Asio4all can’t work with scratch you have to use the Denon driver.


#4

Thanks, it’s a useful tip, but there’s no heacker in me really. Hopefully there is a simpler solution for a Traktor Scratch certified mixer it is if not a legacy product for good, maybe i’ll have to use NI soundcard then.


#5

Why are you not using the denon 64bit asio driver?


#6

Give it a try. I did it. It worked and it’s quite simple. And it saves you from buying a certified interface and having all those cables around. Don’t forget to backup everything before.


#7

It’s a hassle, but yes, I’m the cable guy. As I had the NI A10 already, it saw the light of day again. I might give the recommended hack a try…


#8

As far as I know there is no 64bit Denon driver, that’s what it says on the link I posted as well. No?


#9

X1600 product page:

That support article was made before they released the 64-bit drivers to help users, they forgot to update it (and correct errors).


#10

Hi, thanks. Installed the 64 bit driver, was not aware of it beeing available but still no luck, Scratch disabled, I’ve run out of ideas. Everything is set up ok on the console as well, USB audio is set to ‘channel’, TT’s are on phono inputs, sound is there but Scratch disabled. Timecode signal is ok, so it’s not an cartridge or wiriring issue as well, it works with other soundcard.


#11

Post screenshots of your Traktor preferences: Audio, Output, Input routing. Use imgur for hosting.


#12

Hi, sorry for late answer. Here are the screenshots of Denon Asio driver setup and Denon DN-X1600 asio driver setup. The difference is that fist on shows on Scratch platter “waiting” and other “scratch disabled”.

Scratch used to work in older Traktor 32 bit version with Denon Asio driver. But now with 64 bit Traktor and drivers with none as it’s the topic here.

https://drive.google.com/drive/folders/1Y-Gvv9sjK04RCanl8yQqOfFJ7oicY1Kt?usp=sharing

With both phono/input line “not supported” on audio setup tab.

Thank you


#13

1.) Can you with any ASIO driver switch the traktor decks to internal playback and hear the tracks? 2.) Is the mixer set for routing phono inputs into the interface (refer to user manual) in DVS mode? 3.) Post screenshots of each ASIO driver settings (mixers needs to be shown as connected etc) 4.) Why are you running the sampling rate at 96khz?


#14

With internal playback I got no sound from Traktor no matter what channel presets I choose on the mixer (channel or DVS), Setting USB channel preset to DVS does not give an effect also for DVS signal except when seting chnnel input to Phono (not USB), then Traktor recognizes the Timecode signal and controls the deck but there is no sound returing to the mixer as the channel is not USB. I don’t remember channel presets on mixer beeing set to DVS also before, when it used to work with previous drivers and software. Using DVS preset is not required also by NI guide here:

Changing resolution to less than 96 kbit/s results in no sound also without Scratch. I understand, that the high resolution is not needed sound quality wize. I can’t set anything except buffer size in Denon asio settings: https://drive.google.com/file/d/1pDB6fos5GyrZKNLFn7KNzQ3OAWlF4VT9/view?usp=sharing Sampling rate can be changed through Traktor audio settings (44,1 / 48 / 96).

Thank you for dealing with this. I guess it’s drivers fault, how to uninstall the Denon drivers to reinstall them?


#15

Ok, as I said before, you need to set the phono input to be outputed via USB back into Traktor. This is done in the mixer’s utility settings (page 19 of the manual).


#16

I’ve set channel presets to DVS and the sound should return to mixer via USB as all the channels are routed correctly but it does not. What I noted was that Traktor recocgnizes timecode signal only then when channel input on the DNX1600 mixer is set to line / phono but then the sound is not returned to mixer, just the timecode signal is sent to PC (channel inputs on mixer must be set on USB position not line/phono).

Phono / line settings are disabled: https://drive.google.com/file/d/18IfLCxyFmuftsO4QEK8qjJTRAmDshVbO/view?usp=sharing


#17

Hi i had the same problem when upgrading to Traktor Scratch Pro version 2.11 a few days ago, the mixer wasn’t being recognised in Traktor. I solved it by reverting back to Traktor Scratch Pro version 2.6.8. Heres a download link for it, aslong as you have your Traktor serial number , you should be good to go! Heres the link - Traktor 2.6.8


#18

Download Traktor 2.6.8 from here and use your Traktor serial number to activate. It will work again, I had same problem a few days ago upgrading to version 2.11.


#19

Many thanks, I did not try this yet, but will when I’ll install new Windows, downloaded 2.6.8. Until then I’ll use my mixer through A10.


#20

It is the 32 bit Traktor scratch pro program you was looking for but couldn’t get. Your time codes will work again. Once you click on the Start up wizard and select External controller, Denon dn-x1600 mixer with 2 decks scratch. Select Essential at the top right menu, your platter calibration buttons will appear for both decks. Put needle on vinyl and press Calibrate for each record. You will now be ready to work with mixer. To be able to record, go into preferences, select Mix Recorder, then select External in source and under source in External Source selext Inpiut Deck D. You will now be able to record mixes by selecting on Line 4 channel Usb 7/8 on the matrix switch at the top, click on the small audio tape icon directly above deck B’s letter and the audio recorder will now show.