Serato/Rane SL2/Denon 3900/Hybrid Midi mode


#1

Serato/Rane SL2/Denon 3900/Hybrid Midi mode Issue DJ_CHAINWAX Tue Nov 24, 2015 5:30 am Serato/Rane SL2/Denon 3900/Hybrid Midi mode Issue Hello guys. I am having problems getting my Denon 3900’s setup with Serato in Hybrid Midi Mode.

I am using Serato 1.8/MacBook Pro/Rane SL2/ 2xDenon 3900/ Denon x600 Mixer

I have only ran in USB mode in the past, making the switch. I setup my audio midi on my Macbook. Downloaded the mapping file for Serato and loaded it in Serato.

My left 3900 completely lights up all buttons in hybrid midi mode, my right deck does not. The issue I am having is in Serato, my left deck when I drop a track in starts playing at ridiculously high BPM, sound doesn’t work in DVS. I’m new to this and not sure what I am missing. USB cables are all correct. RCA’s from SL2 box are correct. What am I missing? Any help would be much appreciated. Let me know if I am missing details. Suggestions? • loui425 Tue Nov 24, 2015 10:32 pm Re: Serato/Rane SL2/Denon 3900/Hybrid Midi mode Issue if you go in to the utility settings in the player is the frequency set to serato? not sure that could be it • tsisoundsystem Wed Nov 25, 2015 7:29 pm Re: Serato/Rane SL2/Denon 3900/Hybrid Midi mode Issue if your deck lights up in hybrid midi mode serato dj 1.8 then that deck is not connecting. you will get no lights in serato dj on your decks as light support for denon sc3900 and all denon table top does not work at this time in serato dj. A powered usb hub is need for connecting the 2 sc3900 and the mixer before connecting to the laptop as a mac only has 2 usb • DJ_CHAINWAX Thu Nov 26, 2015 12:17 am Re: Serato/Rane SL2/Denon 3900/Hybrid Midi mode Issue Hey guys, thanks for the response.

I have the 3900 setup for Serato in the preset settings and the correct hz.

I have the powered USB hooked up, interesting though, I didn’t know about the lighting thing. I will try some different usb cords out tonight to see if that makes a difference. Is there any settings in Serato I could be missing? Maybe the mapping file isn’t loading properly? • tsisoundsystem Sat Nov 28, 2015 4:27 am Re: Serato/Rane SL2/Denon 3900/Hybrid Midi mode Issue you can also check the rpm speed make sure that the one on the 3900 and the rpm speed in the software is the same 45 rpm decks and software, not 45 rpm decks and 33 software. Also check midi assign on the decks it should be deck 1 midi 5 and deck 2 midi 6.